Deepak Kodihalli | 14c47d2 | 2017-03-17 03:51:13 -0500 | [diff] [blame] | 1 | SUMMARY = "Open POWER DBus Interfaces" |
| 2 | DESCRIPTION = "Generated bindings, using sdbus++, for the openpower YAML" |
| 3 | PR = "r1" |
Patrick Venture | 92feebc | 2018-10-02 19:51:03 -0700 | [diff] [blame] | 4 | PV = "1.0+git${SRCPV}" |
Patrick Venture | f9afb7a | 2018-11-03 09:10:39 -0700 | [diff] [blame^] | 5 | LICENSE = "Apache-2.0" |
| 6 | LIC_FILES_CHKSUM = "file://LICENSE;md5=e3fc50a88d0a364313df4b21ef20c29e" |
Deepak Kodihalli | 14c47d2 | 2017-03-17 03:51:13 -0500 | [diff] [blame] | 7 | |
| 8 | S = "${WORKDIR}/git" |
| 9 | |
| 10 | inherit autotools pkgconfig |
Deepak Kodihalli | 14c47d2 | 2017-03-17 03:51:13 -0500 | [diff] [blame] | 11 | inherit pythonnative |
Marri Devender Rao | 8dd7798 | 2017-05-29 01:33:26 -0500 | [diff] [blame] | 12 | inherit phosphor-dbus-yaml |
Deepak Kodihalli | 14c47d2 | 2017-03-17 03:51:13 -0500 | [diff] [blame] | 13 | |
| 14 | DEPENDS += "autoconf-archive-native" |
| 15 | DEPENDS += "sdbus++-native" |
| 16 | |
Deepak Kodihalli | 14c47d2 | 2017-03-17 03:51:13 -0500 | [diff] [blame] | 17 | SRC_URI += "git://github.com/openbmc/openpower-dbus-interfaces" |
Andrew Geissler | 262e3ef | 2018-10-05 01:30:11 +0000 | [diff] [blame] | 18 | SRCREV = "998a82ec587be23bc5c2e59ba858fb099279c5f0" |
Deepak Kodihalli | 14c47d2 | 2017-03-17 03:51:13 -0500 | [diff] [blame] | 19 | |
| 20 | DEPENDS_remove_class-native = "sdbus++-native" |
| 21 | DEPENDS_remove_class-nativesdk = "sdbus++-native" |
| 22 | |
| 23 | PACKAGECONFIG ??= "libopenpower_dbus" |
| 24 | PACKAGECONFIG[libopenpower_dbus] = " \ |
| 25 | --enable-libopenpower_dbus, \ |
| 26 | --disable-libopenpower_dbus, \ |
| 27 | systemd sdbusplus, \ |
| 28 | libsystemd sdbusplus \ |
| 29 | " |
| 30 | |
| 31 | PACKAGECONFIG_remove_class-native = "libopenpower_dbus" |
| 32 | PACKAGECONFIG_remove_class-nativesdk = "libopenpower_dbus" |
| 33 | |
| 34 | BBCLASSEXTEND += "native nativesdk" |