Patrick Williams | c124f4f | 2015-09-15 14:41:29 -0500 | [diff] [blame] | 1 | SUMMARY = "Example of how to build an external Linux kernel module" |
| 2 | LICENSE = "GPLv2" |
| 3 | LIC_FILES_CHKSUM = "file://COPYING;md5=12f884d2ae1ff87c09e5b7ccc2c4ca7e" |
| 4 | |
| 5 | inherit module |
| 6 | |
| 7 | SRC_URI = "file://Makefile \ |
| 8 | file://hello.c \ |
| 9 | file://COPYING \ |
| 10 | " |
| 11 | |
| 12 | S = "${WORKDIR}" |
| 13 | |
| 14 | # The inherit of module.bbclass will automatically name module packages with |
| 15 | # "kernel-module-" prefix as required by the oe-core build environment. |
Brad Bishop | 316dfdd | 2018-06-25 12:45:53 -0400 | [diff] [blame] | 16 | |
| 17 | RPROVIDES_${PN} += "kernel-module-hello" |