Andrew Geissler | 635e0e4 | 2020-08-21 15:58:33 -0500 | [diff] [blame] | 1 | SUMMARY = "Library for parsing command line options" |
Andrew Geissler | 90fd73c | 2021-03-05 15:25:55 -0600 | [diff] [blame] | 2 | DESCRIPTION = "Popt is a C library for parsing command line parameters. Popt was heavily influenced by the getopt() and getopt_long() functions, but it improves on them by allowing more powerful argument expansion. Popt can parse arbitrary argv[] style arrays and automatically set variables based on command line arguments." |
Andrew Geissler | 635e0e4 | 2020-08-21 15:58:33 -0500 | [diff] [blame] | 3 | HOMEPAGE = "https://www.rpm.org/" |
| 4 | SECTION = "libs" |
| 5 | |
| 6 | LICENSE = "MIT" |
| 7 | LIC_FILES_CHKSUM = "file://COPYING;md5=cb0613c30af2a8249b8dcc67d3edb06d" |
| 8 | |
| 9 | DEPENDS = "virtual/libiconv" |
| 10 | |
Patrick Williams | de0582f | 2022-04-08 10:23:27 -0500 | [diff] [blame] | 11 | SRC_URI = "\ |
| 12 | http://ftp.rpm.org/popt/releases/popt-1.x/${BP}.tar.gz \ |
| 13 | file://0001-popt-test-output-format-for-ptest.patch \ |
| 14 | file://run-ptest \ |
| 15 | " |
Andrew Geissler | 635e0e4 | 2020-08-21 15:58:33 -0500 | [diff] [blame] | 16 | SRC_URI[sha256sum] = "5159bc03a20b28ce363aa96765f37df99ea4d8850b1ece17d1e6ad5c24fdc5d1" |
| 17 | |
Patrick Williams | de0582f | 2022-04-08 10:23:27 -0500 | [diff] [blame] | 18 | inherit autotools gettext ptest |
| 19 | |
Andrew Geissler | 615f2f1 | 2022-07-15 14:00:58 -0500 | [diff] [blame] | 20 | RDEPENDS:${PN}-ptest += "bash" |
Patrick Williams | de0582f | 2022-04-08 10:23:27 -0500 | [diff] [blame] | 21 | |
| 22 | do_compile_ptest() { |
| 23 | sed 's#lt-test1#test1#g' ${S}/tests/testit.sh > ${B}/tests/testit.sh |
| 24 | } |
| 25 | |
| 26 | do_install_ptest() { |
| 27 | install ${B}/tests/.libs/test* ${D}/${PTEST_PATH} |
| 28 | install ${B}/tests/.libs/tdict ${D}/${PTEST_PATH} |
| 29 | install ${B}/tests/testit.sh ${D}/${PTEST_PATH} |
| 30 | install ${B}/tests/test-poptrc ${D}/${PTEST_PATH} |
| 31 | } |
Andrew Geissler | 635e0e4 | 2020-08-21 15:58:33 -0500 | [diff] [blame] | 32 | |
| 33 | BBCLASSEXTEND = "native nativesdk" |