blob: 671fe4f23acca58eedd7073ac694cd87618533fc [file] [log] [blame]
Andrew Geissler82c905d2020-04-13 13:39:40 -05001SUMMARY = "Python bindings and utilities for GeoJSON"
2HOMEPAGE = "https://pypi.org/project/geojson/"
Andrew Geissler5199d832021-09-24 16:47:35 -05003LICENSE = "BSD-3-Clause"
Andrew Geisslerfc113ea2023-03-31 09:59:46 -05004LIC_FILES_CHKSUM = "file://LICENSE.rst;md5=f77f2ed49768c8d4c79ba874c0f94d8a"
Andrew Geissler82c905d2020-04-13 13:39:40 -05005
Andrew Geisslerfc113ea2023-03-31 09:59:46 -05006SRC_URI[sha256sum] = "ff3d75acab60b1e66504a11f7ea12c104bad32ff3c410a807788663b966dee4a"
Andrew Geissler82c905d2020-04-13 13:39:40 -05007
Andrew Geisslerc87764f2020-06-27 00:16:32 -05008inherit pypi setuptools3 ptest
9
10SRC_URI += " \
11 file://run-ptest \
12"
13
Patrick Williams213cb262021-08-07 19:21:33 -050014RDEPENDS:${PN}-ptest += " \
Andrew Geisslerc87764f2020-06-27 00:16:32 -050015 ${PYTHON_PN}-pytest \
16"
17
18do_install_ptest() {
19 install -d ${D}${PTEST_PATH}/tests
20 cp -rf ${S}/tests/* ${D}${PTEST_PATH}/tests/
21}
Andrew Geissler82c905d2020-04-13 13:39:40 -050022
Patrick Williams213cb262021-08-07 19:21:33 -050023RDEPENDS:${PN} += "python3-simplejson python3-math"
Andrew Geissler82c905d2020-04-13 13:39:40 -050024
25BBCLASSEXTEND = "native nativesdk"