Andrew Geissler | 9aee500 | 2022-03-30 16:27:02 +0000 | [diff] [blame] | 1 | SUMMARY = "Provides both a high- and low-level interface to the HDF5 library from Python." |
| 2 | HOMEPAGE = "https://www.h5py.org/" |
| 3 | SECTION = "devel/python" |
| 4 | LICENSE = "BSD-3-Clause" |
| 5 | LIC_FILES_CHKSUM = "file://LICENSE;md5=113251d71fb0384712c719b567261c5c" |
| 6 | |
Andrew Geissler | fc113ea | 2023-03-31 09:59:46 -0500 | [diff] [blame^] | 7 | SRC_URI[sha256sum] = "6fead82f0c4000cf38d53f9c030780d81bfa0220218aee13b90b7701c937d95f" |
Andrew Geissler | 9aee500 | 2022-03-30 16:27:02 +0000 | [diff] [blame] | 8 | |
Andrew Geissler | fc113ea | 2023-03-31 09:59:46 -0500 | [diff] [blame^] | 9 | SRC_URI += "file://0001-setup_build.py-avoid-absolute-path.patch" |
Andrew Geissler | 9aee500 | 2022-03-30 16:27:02 +0000 | [diff] [blame] | 10 | |
| 11 | inherit pkgconfig pypi setuptools3 |
| 12 | |
| 13 | BBCLASSEXTEND = "native" |
| 14 | |
| 15 | DEPENDS = "python3-pkgconfig-native \ |
| 16 | python3-cython-native \ |
| 17 | python3-numpy-native \ |
| 18 | python3-six-native \ |
| 19 | hdf5-native \ |
| 20 | python3 \ |
| 21 | hdf5 \ |
| 22 | " |
| 23 | |
| 24 | RDEPENDS:${PN} = "python3-numpy \ |
| 25 | python3-six \ |
| 26 | python3-json \ |
| 27 | " |
| 28 | |
Andrew Geissler | fc113ea | 2023-03-31 09:59:46 -0500 | [diff] [blame^] | 29 | export HDF5_VERSION="1.14.0" |