Andrew Geissler | fc113ea | 2023-03-31 09:59:46 -0500 | [diff] [blame^] | 1 | SUMMARY = "Ninja is a small build system with a focus on speed" |
| 2 | LICENSE = "Apache-2.0" |
| 3 | LIC_FILES_CHKSUM = "file://LICENSE_Apache_20;md5=19cbd64715b51267a47bf3750cc6a8a5" |
| 4 | |
| 5 | DEPENDS = "ninja-native cmake-native python3-scikit-build-native" |
| 6 | |
| 7 | PYPI_PACKAGE = "ninja" |
| 8 | PYPI_ARCHIVE_NAME_PREFIX = "pypi-" |
| 9 | |
| 10 | inherit pypi python_setuptools_build_meta |
| 11 | SRC_URI[sha256sum] = "c833a47d39b2d1eee3f9ca886fa1581efd5be6068b82734ac229961ee8748f90" |
| 12 | |
| 13 | SRC_URI += " \ |
| 14 | file://CMakeLists.txt \ |
| 15 | file://run-ninja-from-path.patch \ |
| 16 | " |
| 17 | |
| 18 | addtask do_patchbuild after do_patch before do_configure |
| 19 | |
| 20 | do_patchbuild () { |
| 21 | rm -f ${S}/CMakeLists.txt |
| 22 | cp ${WORKDIR}/CMakeLists.txt ${S}/ |
| 23 | } |
| 24 | |
| 25 | do_install:append () { |
| 26 | rm -rf ${D}${bindir} |
| 27 | } |
| 28 | |
| 29 | RDEPENDS:${PN} = " \ |
| 30 | ninja \ |
| 31 | python3-scikit-build \ |
| 32 | " |
| 33 | |
| 34 | BBCLASSEXTEND = "native nativesdk" |