Andrew Geissler | 517393d | 2023-01-13 08:55:19 -0600 | [diff] [blame] | 1 | SUMMARY = "Library for parsing command line options" |
| 2 | DESCRIPTION = "Popt is a C library for parsing command line parameters. Popt was heavily influenced by the getopt() and getopt_long() functions, but it improves on them by allowing more powerful argument expansion. Popt can parse arbitrary argv[] style arrays and automatically set variables based on command line arguments." |
| 3 | HOMEPAGE = "https://www.rpm.org/" |
| 4 | SECTION = "libs" |
| 5 | |
| 6 | LICENSE = "MIT" |
| 7 | LIC_FILES_CHKSUM = "file://COPYING;md5=e0206ac9471d06667e076212db20c5f4" |
| 8 | |
| 9 | DEPENDS = "virtual/libiconv" |
| 10 | |
| 11 | SRC_URI = "http://ftp.rpm.org/popt/releases/popt-1.x/${BP}.tar.gz \ |
| 12 | file://run-ptest \ |
| 13 | " |
| 14 | SRC_URI[sha256sum] = "c25a4838fc8e4c1c8aacb8bd620edb3084a3d63bf8987fdad3ca2758c63240f9" |
| 15 | |
| 16 | inherit autotools gettext ptest |
| 17 | |
| 18 | RDEPENDS:${PN}-ptest += "bash" |
| 19 | |
| 20 | do_compile_ptest() { |
| 21 | sed 's#lt-test1#test1#g' ${S}/tests/testit.sh > ${B}/tests/testit.sh |
| 22 | } |
| 23 | |
| 24 | do_install_ptest() { |
| 25 | install ${B}/tests/.libs/test* ${D}/${PTEST_PATH} |
| 26 | install ${B}/tests/.libs/tdict ${D}/${PTEST_PATH} |
| 27 | install ${B}/tests/testit.sh ${D}/${PTEST_PATH} |
| 28 | install ${B}/tests/test-poptrc ${D}/${PTEST_PATH} |
| 29 | } |
| 30 | |
| 31 | BBCLASSEXTEND = "native nativesdk" |