Brad Bishop | 316dfdd | 2018-06-25 12:45:53 -0400 | [diff] [blame] | 1 | SUMMARY = "Dependency management tool for Golang" |
| 2 | HOMEPAGE = "https://github.com/golang/dep" |
| 3 | LICENSE = "BSD-3-Clause" |
| 4 | LIC_FILES_CHKSUM = "file://src/${GO_IMPORT}/LICENSE;md5=1bad315647751fab0007812f70d42c0d" |
| 5 | |
| 6 | GO_IMPORT = "github.com/golang/dep" |
| 7 | SRC_URI = "git://${GO_IMPORT} \ |
| 8 | file://0001-Add-support-for-mips-mips64.patch;patchdir=src/github.com/golang/dep \ |
| 9 | " |
| 10 | |
| 11 | # Points to 0.4.1 tag |
| 12 | SRCREV = "37d9ea0ac16f0e0a05afc3b60e1ac8c364b6c329" |
| 13 | |
| 14 | inherit go |
| 15 | |
| 16 | GO_INSTALL = "${GO_IMPORT}/cmd/dep" |
| 17 | |
| 18 | RDEPENDS_${PN}-dev += "bash" |
| 19 | |
| 20 | BBCLASSEXTEND = "native nativesdk" |