Patrick Williams | d849ec7 | 2016-08-17 14:59:38 -0500 | [diff] [blame] | 1 | SECTION = "devel" |
| 2 | SUMMARY = "Light-weight package to set up cgroups at system boot." |
| 3 | DESCRIPTION = "Light-weight package to set up cgroups at system boot." |
| 4 | HOMEPAGE = "http://packages.ubuntu.com/source/precise/cgroup-lite" |
| 5 | LICENSE = "GPLv2" |
| 6 | LIC_FILES_CHKSUM = "file://debian/copyright;md5=5d5da4e0867cf06014f87102154d0102" |
| 7 | SRC_URI = "http://archive.ubuntu.com/ubuntu/pool/main/c/cgroup-lite/cgroup-lite_1.1.tar.gz" |
| 8 | SRC_URI += "file://cgroups-init" |
| 9 | SRC_URI[md5sum] = "041a0d8ad2b192271a2e5507fdb6809f" |
| 10 | SRC_URI[sha256sum] = "e7f9992b90b5b4634f3b8fb42580ff28ff31093edb297ab872c37f61a94586bc" |
| 11 | |
| 12 | inherit update-rc.d |
| 13 | |
| 14 | INITSCRIPT_NAME = "cgroups-init" |
| 15 | INITSCRIPT_PARAMS = "start 8 2 3 4 5 . stop 20 0 1 6 ." |
| 16 | do_install() { |
| 17 | install -d ${D}/bin |
| 18 | install -d ${D}${sysconfdir}/init.d |
| 19 | install -m 0755 ${S}/scripts/cgroups-mount ${D}/bin |
| 20 | install -m 0755 ${S}/scripts/cgroups-umount ${D}/bin |
| 21 | install -m 0755 ${WORKDIR}/cgroups-init ${D}${sysconfdir}/init.d/cgroups-init |
| 22 | } |