Brad Bishop | c342db3 | 2019-05-15 21:57:59 -0400 | [diff] [blame] | 1 | SUMMARY = "GNU Project parser generator (yacc replacement)" |
| 2 | DESCRIPTION = "Bison is a general-purpose parser generator that converts an annotated context-free grammar into \ |
| 3 | an LALR(1) or GLR parser for that grammar. Bison is upward compatible with Yacc: all properly-written Yacc \ |
| 4 | grammars ought to work with Bison with no change. Anyone familiar with Yacc should be able to use Bison with \ |
| 5 | little trouble." |
| 6 | HOMEPAGE = "http://www.gnu.org/software/bison/" |
| 7 | LICENSE = "GPLv3" |
| 8 | LIC_FILES_CHKSUM = "file://COPYING;md5=d32239bcb673463ab874e80d47fae504" |
| 9 | SECTION = "devel" |
| 10 | DEPENDS = "bison-native flex-native" |
| 11 | |
| 12 | SRC_URI = "${GNU_MIRROR}/bison/bison-${PV}.tar.xz \ |
| 13 | file://dont-depend-on-help2man.patch.patch \ |
| 14 | file://add-with-bisonlocaledir.patch \ |
| 15 | " |
| 16 | |
| 17 | # No point in hardcoding path to m4, just use PATH |
| 18 | EXTRA_OECONF += "M4=m4" |
| 19 | |
Brad Bishop | 15ae250 | 2019-06-18 21:44:24 -0400 | [diff] [blame] | 20 | SRC_URI[md5sum] = "c9b552dee234b2f6b66e56b27e5234c9" |
| 21 | SRC_URI[sha256sum] = "039ee45b61d95e5003e7e8376f9080001b4066ff357bde271b7faace53b9d804" |
Brad Bishop | c342db3 | 2019-05-15 21:57:59 -0400 | [diff] [blame] | 22 | |
| 23 | inherit autotools gettext texinfo |
| 24 | |
| 25 | # The automatic m4 path detection gets confused, so force the right value |
| 26 | acpaths = "-I ${S}/m4" |
| 27 | |
| 28 | do_compile_prepend() { |
| 29 | for i in mfcalc calc++ rpcalc; do mkdir -p ${B}/examples/$i; done |
| 30 | } |
| 31 | |
| 32 | do_install_append_class-native() { |
| 33 | create_wrapper ${D}/${bindir}/bison \ |
| 34 | BISON_PKGDATADIR=${STAGING_DATADIR_NATIVE}/bison |
| 35 | } |
| 36 | do_install_append_class-nativesdk() { |
| 37 | create_wrapper ${D}/${bindir}/bison \ |
| 38 | BISON_PKGDATADIR=${datadir}/bison |
| 39 | } |
| 40 | BBCLASSEXTEND = "native nativesdk" |