Brad Bishop | d7bf8c1 | 2018-02-25 22:55:05 -0500 | [diff] [blame] | 1 | SUMMARY = "The GNU portability library" |
| 2 | DESCRIPTION = "A collection of software subroutines which are designed to \ |
| 3 | be usable on many operating systems. The goal of the project \ |
| 4 | is to make it easy for free software authors to make their \ |
| 5 | software run on many operating systems. Since source is designed \ |
| 6 | to be copied from gnulib, it is not a library per-se, as much \ |
| 7 | as a collection of portable idioms to be used in other projects." |
| 8 | |
| 9 | HOMEPAGE = "http://www.gnu.org/software/gnulib/" |
| 10 | SECTION = "devel" |
| 11 | LICENSE = "LGPLv2+" |
| 12 | |
| 13 | LIC_FILES_CHKSUM = "file://COPYING;md5=56a22a6e5bcce45e2c8ac184f81412b5" |
| 14 | SRCREV = "b23000de1e47c7d580e0e220966dd1ee42a5e5bc" |
| 15 | |
| 16 | SRC_URI = "git://git.sv.gnu.org/gnulib;protocol=git \ |
| 17 | " |
| 18 | |
| 19 | S = "${WORKDIR}/git" |
| 20 | |
| 21 | do_install () { |
| 22 | cd ${S} |
| 23 | git checkout master |
| 24 | git clone ${S} ${D}/${datadir}/gnulib |
| 25 | } |
| 26 | |
| 27 | do_patch[noexec] = "1" |
| 28 | do_configure[noexec] = "1" |
| 29 | do_compile[noexec] = "1" |
| 30 | do_package[noexec] = "1" |
| 31 | do_packagedata[noexec] = "1" |
Brad Bishop | 316dfdd | 2018-06-25 12:45:53 -0400 | [diff] [blame] | 32 | deltask package_write_ipk |
| 33 | deltask package_write_deb |
| 34 | deltask package_write_rpm |
Brad Bishop | d7bf8c1 | 2018-02-25 22:55:05 -0500 | [diff] [blame] | 35 | |
| 36 | BBCLASSEXTEND = "native" |