Brad Bishop | 6e60e8b | 2018-02-01 10:27:11 -0500 | [diff] [blame] | 1 | SUMMARY = "Lightweight and minimal (~20K) dumb-terminal emulation program" |
| 2 | SECTION = "console/utils" |
| 3 | LICENSE = "GPLv2+" |
| 4 | HOMEPAGE = "http://code.google.com/p/picocom/" |
| 5 | LIC_FILES_CHKSUM = "file://LICENSE.txt;md5=3000e4830620e310fe65c0eb69df9e8a" |
| 6 | |
| 7 | BASEPV = "2.2" |
| 8 | PV = "${BASEPV}+git${SRCPV}" |
| 9 | |
| 10 | SRCREV = "deffd18c24145bd6f965f44e735a50b65810ccdc" |
| 11 | |
| 12 | SRC_URI = "git://github.com/npat-efault/picocom" |
| 13 | |
| 14 | S = "${WORKDIR}/git" |
| 15 | |
| 16 | EXTRA_OEMAKE = "'CC=${CC}' 'LD=${CC}' 'VERSION=${BASEPV}' \ |
| 17 | 'CFLAGS=${CFLAGS}' 'LDFLAGS=${LDFLAGS}' " |
| 18 | |
| 19 | do_install () { |
| 20 | install -d ${D}${bindir} |
| 21 | install -m 0755 ${BPN} pcasc pcxm pcym pczm ${D}${bindir}/ |
| 22 | } |
| 23 | |