Andrew Geissler | 595f630 | 2022-01-24 19:11:47 +0000 | [diff] [blame] | 1 | SUMMARY = "JSON C++ lib used to read and write json file." |
| 2 | DESCRIPTION = "Jsoncpp is an implementation of a JSON (http://json.org) reader \ |
| 3 | and writer in C++. JSON (JavaScript Object Notation) is a \ |
| 4 | lightweight data-interchange format. It is easy for humans to \ |
| 5 | read and write. It is easy for machines to parse and generate." |
| 6 | |
| 7 | HOMEPAGE = "https://github.com/open-source-parsers/jsoncpp" |
| 8 | |
| 9 | SECTION = "libs" |
| 10 | |
| 11 | LICENSE = "MIT" |
| 12 | LIC_FILES_CHKSUM = "file://LICENSE;md5=5d73c165a0f9e86a1342f32d19ec5926" |
| 13 | |
| 14 | PE = "1" |
| 15 | |
| 16 | SRCREV = "5defb4ed1a4293b8e2bf641e16b156fb9de498cc" |
| 17 | SRC_URI = "git://github.com/open-source-parsers/jsoncpp;branch=master;protocol=https" |
| 18 | |
| 19 | S = "${WORKDIR}/git" |
| 20 | |
| 21 | inherit cmake |
| 22 | |
| 23 | EXTRA_OECMAKE += "-DBUILD_SHARED_LIBS=ON -DBUILD_OBJECT_LIBS=OFF -DJSONCPP_WITH_TESTS=OFF" |
| 24 | |
| 25 | BBCLASSEXTEND = "native" |