Brad Bishop | 1932369 | 2019-04-05 15:28:33 -0400 | [diff] [blame] | 1 | SUMMARY = "Universal Addresses to RPC Program Number Mapper" |
| 2 | DESCRIPTION = "The rpcbind utility is a server that converts RPC \ |
| 3 | program numbers into universal addresses." |
| 4 | SECTION = "console/network" |
| 5 | HOMEPAGE = "http://sourceforge.net/projects/rpcbind/" |
| 6 | BUGTRACKER = "http://sourceforge.net/tracker/?group_id=201237&atid=976751" |
| 7 | DEPENDS = "libtirpc quota" |
| 8 | |
| 9 | LICENSE = "BSD" |
| 10 | LIC_FILES_CHKSUM = "file://COPYING;md5=b46486e4c4a416602693a711bb5bfa39 \ |
| 11 | file://src/rpcinfo.c;beginline=1;endline=27;md5=f8a8cd2cb25ac5aa16767364fb0e3c24" |
| 12 | |
| 13 | SRC_URI = "${SOURCEFORGE_MIRROR}/rpcbind/rpcbind-${PV}.tar.bz2 \ |
| 14 | file://init.d \ |
| 15 | file://rpcbind.conf \ |
| 16 | file://rpcbind.socket \ |
| 17 | file://rpcbind.service \ |
| 18 | file://rpcbind_add_option_to_fix_port_number.patch \ |
| 19 | " |
| 20 | SRC_URI[md5sum] = "ed46f09b9c0fa2d49015f6431bc5ea7b" |
| 21 | SRC_URI[sha256sum] = "2ce360683963b35c19c43f0ee2c7f18aa5b81ef41c3fdbd15ffcb00b8bffda7a" |
| 22 | |
| 23 | inherit autotools update-rc.d systemd pkgconfig |
| 24 | |
| 25 | PACKAGECONFIG ??= "tcp-wrappers" |
| 26 | PACKAGECONFIG[tcp-wrappers] = "--enable-libwrap,--disable-libwrap,tcp-wrappers" |
| 27 | |
| 28 | INITSCRIPT_NAME = "rpcbind" |
| 29 | INITSCRIPT_PARAMS = "start 12 2 3 4 5 . stop 60 0 1 6 ." |
| 30 | |
| 31 | SYSTEMD_SERVICE_${PN} = "rpcbind.service" |
| 32 | |
| 33 | inherit useradd |
| 34 | |
| 35 | USERADD_PACKAGES = "${PN}" |
| 36 | USERADD_PARAM_${PN} = "--system --no-create-home --home-dir / \ |
| 37 | --shell /bin/false --user-group rpc" |
| 38 | |
| 39 | PACKAGECONFIG ??= "${@bb.utils.filter('DISTRO_FEATURES', 'systemd', d)}" |
| 40 | PACKAGECONFIG[systemd] = "--with-systemdsystemunitdir=${systemd_unitdir}/system/, \ |
| 41 | --without-systemdsystemunitdir, \ |
| 42 | systemd \ |
| 43 | " |
| 44 | |
| 45 | EXTRA_OECONF += " --enable-warmstarts --with-rpcuser=rpc" |
| 46 | |
| 47 | do_install_append () { |
| 48 | install -d ${D}${sysconfdir}/init.d |
| 49 | sed -e 's,/etc/,${sysconfdir}/,g' \ |
| 50 | -e 's,/sbin/,${sbindir}/,g' \ |
| 51 | ${WORKDIR}/init.d > ${D}${sysconfdir}/init.d/rpcbind |
| 52 | chmod 0755 ${D}${sysconfdir}/init.d/rpcbind |
| 53 | |
| 54 | install -m 0755 ${WORKDIR}/rpcbind.conf ${D}${sysconfdir} |
| 55 | install -d ${D}${systemd_unitdir}/system |
| 56 | install -m 0644 ${WORKDIR}/rpcbind.socket ${D}${systemd_unitdir}/system |
| 57 | install -m 0644 ${WORKDIR}/rpcbind.service ${D}${systemd_unitdir}/system |
| 58 | sed -i -e 's,@SBINDIR@,${sbindir},g' \ |
| 59 | -e 's,@SYSCONFDIR@,${sysconfdir},g' \ |
| 60 | ${D}${systemd_unitdir}/system/rpcbind.service |
| 61 | } |