Andrew Geissler | 82c905d | 2020-04-13 13:39:40 -0500 | [diff] [blame] | 1 | SUMMARY = "A library to abstract stream I/O like serial port, TCP, telnet, etc" |
| 2 | HOMEPAGE = "https://github.com/cminyard/gensio" |
| 3 | LICENSE = "GPL-2.0 & LGPL-2.1" |
| 4 | LIC_FILES_CHKSUM = "file://COPYING.LIB;md5=a0fd36908af843bcee10cb6dfc47fa67 \ |
| 5 | file://COPYING;md5=bae3019b4c6dc4138c217864bd04331f \ |
| 6 | " |
| 7 | |
Patrick Williams | 213cb26 | 2021-08-07 19:21:33 -0500 | [diff] [blame] | 8 | SRCREV = "78b30dc952512c98db8c2e7e0eded2982b802b93" |
Andrew Geissler | 82c905d | 2020-04-13 13:39:40 -0500 | [diff] [blame] | 9 | |
Andrew Geissler | ac970dd | 2021-02-12 15:32:45 -0600 | [diff] [blame] | 10 | SRC_URI = "git://github.com/cminyard/gensio;protocol=https;branch=2.2.x" |
Andrew Geissler | 82c905d | 2020-04-13 13:39:40 -0500 | [diff] [blame] | 11 | |
| 12 | S = "${WORKDIR}/git" |
| 13 | |
| 14 | inherit autotools |
| 15 | |
| 16 | PACKAGECONFIG ??= "openssl tcp-wrappers" |
| 17 | |
| 18 | PACKAGECONFIG[openssl] = "--with-openssl=${STAGING_DIR_HOST}${prefix},--without-openssl, openssl" |
| 19 | PACKAGECONFIG[tcp-wrappers] = "--with-tcp-wrappers,--without-tcp-wrappers, tcp-wrappers" |
| 20 | PACKAGECONFIG[swig] = "--with-swig,--without-swig, swig" |
| 21 | |
| 22 | EXTRA_OECONF = "--without-python" |
| 23 | |
Patrick Williams | 213cb26 | 2021-08-07 19:21:33 -0500 | [diff] [blame] | 24 | RDEPENDS:${PN} += "bash" |