| SUMMARY = "A sophisticated Numeric Processing Package for Python" |
| SECTION = "devel/python" |
| LICENSE = "BSD-3-Clause & BSD-2-Clause & PSF & Apache-2.0 & BSD & MIT" |
| LIC_FILES_CHKSUM = "file://LICENSE.txt;md5=e527e2a94c4584cd192d03ffb1f4a744" |
| |
| SRCNAME = "numpy" |
| |
| SRC_URI = "https://github.com/${SRCNAME}/${SRCNAME}/releases/download/v${PV}/${SRCNAME}-${PV}.tar.gz \ |
| file://0001-Don-t-search-usr-and-so-on-for-libraries-by-default-.patch \ |
| file://0001-numpy-core-Define-RISCV-32-support.patch \ |
| file://run-ptest \ |
| " |
| SRC_URI[sha256sum] = "fe836a685d6838dbb3f603caef01183ea98e88febf4ce956a2ea484a75378413" |
| |
| UPSTREAM_CHECK_URI = "https://github.com/numpy/numpy/releases" |
| UPSTREAM_CHECK_REGEX = "(?P<pver>\d+(\.\d+)+)\.tar" |
| |
| DEPENDS += "python3-cython-native" |
| |
| inherit ptest setuptools3 |
| |
| S = "${WORKDIR}/numpy-${PV}" |
| |
| CLEANBROKEN = "1" |
| |
| FILES_${PN}-staticdev += "${PYTHON_SITEPACKAGES_DIR}/numpy/core/lib/*.a ${PYTHON_SITEPACKAGES_DIR}/numpy/random/lib/*.a" |
| |
| # install what is needed for numpy.test() |
| RDEPENDS_${PN} = "${PYTHON_PN}-unittest \ |
| ${PYTHON_PN}-difflib \ |
| ${PYTHON_PN}-pprint \ |
| ${PYTHON_PN}-pickle \ |
| ${PYTHON_PN}-shell \ |
| ${PYTHON_PN}-doctest \ |
| ${PYTHON_PN}-datetime \ |
| ${PYTHON_PN}-distutils \ |
| ${PYTHON_PN}-misc \ |
| ${PYTHON_PN}-mmap \ |
| ${PYTHON_PN}-netclient \ |
| ${PYTHON_PN}-numbers \ |
| ${PYTHON_PN}-pydoc \ |
| ${PYTHON_PN}-pkgutil \ |
| ${PYTHON_PN}-email \ |
| ${PYTHON_PN}-compression \ |
| ${PYTHON_PN}-ctypes \ |
| ${PYTHON_PN}-threading \ |
| ${PYTHON_PN}-multiprocessing \ |
| " |
| RDEPENDS_${PN}-ptest += "${PYTHON_PN}-pytest \ |
| ${PYTHON_PN}-hypothesis \ |
| ${PYTHON_PN}-sortedcontainers \ |
| ${PYTHON_PN}-resource \ |
| ldd \ |
| " |
| |
| RDEPENDS_${PN}_class-native = "" |
| |
| BBCLASSEXTEND = "native nativesdk" |