Brad Bishop | 316dfdd | 2018-06-25 12:45:53 -0400 | [diff] [blame] | 1 | SUMMARY = "A sophisticated Numeric Processing Package for Python" |
| 2 | SECTION = "devel/python" |
Brad Bishop | 79641f2 | 2019-09-10 07:20:22 -0400 | [diff] [blame] | 3 | LICENSE = "BSD-3-Clause & BSD-2-Clause & PSF & Apache-2.0 & BSD & MIT" |
Andrew Geissler | 6ce62a2 | 2020-11-30 19:58:47 -0600 | [diff] [blame] | 4 | LIC_FILES_CHKSUM = "file://LICENSE.txt;md5=e527e2a94c4584cd192d03ffb1f4a744" |
Brad Bishop | 316dfdd | 2018-06-25 12:45:53 -0400 | [diff] [blame] | 5 | |
| 6 | SRCNAME = "numpy" |
| 7 | |
| 8 | SRC_URI = "https://github.com/${SRCNAME}/${SRCNAME}/releases/download/v${PV}/${SRCNAME}-${PV}.tar.gz \ |
| 9 | file://0001-Don-t-search-usr-and-so-on-for-libraries-by-default-.patch \ |
Andrew Geissler | 6ce62a2 | 2020-11-30 19:58:47 -0600 | [diff] [blame] | 10 | file://0001-numpy-core-Define-RISCV-32-support.patch \ |
| 11 | file://run-ptest \ |
| 12 | " |
| 13 | SRC_URI[sha256sum] = "fe836a685d6838dbb3f603caef01183ea98e88febf4ce956a2ea484a75378413" |
Brad Bishop | 316dfdd | 2018-06-25 12:45:53 -0400 | [diff] [blame] | 14 | |
| 15 | UPSTREAM_CHECK_URI = "https://github.com/numpy/numpy/releases" |
| 16 | UPSTREAM_CHECK_REGEX = "(?P<pver>\d+(\.\d+)+)\.tar" |
| 17 | |
Andrew Geissler | 82c905d | 2020-04-13 13:39:40 -0500 | [diff] [blame] | 18 | DEPENDS += "python3-cython-native" |
| 19 | |
Andrew Geissler | 6ce62a2 | 2020-11-30 19:58:47 -0600 | [diff] [blame] | 20 | inherit ptest setuptools3 |
| 21 | |
Brad Bishop | 316dfdd | 2018-06-25 12:45:53 -0400 | [diff] [blame] | 22 | S = "${WORKDIR}/numpy-${PV}" |
| 23 | |
Brad Bishop | 1a4b7ee | 2018-12-16 17:11:34 -0800 | [diff] [blame] | 24 | CLEANBROKEN = "1" |
| 25 | |
Andrew Geissler | 475cb72 | 2020-07-10 16:00:51 -0500 | [diff] [blame] | 26 | FILES_${PN}-staticdev += "${PYTHON_SITEPACKAGES_DIR}/numpy/core/lib/*.a ${PYTHON_SITEPACKAGES_DIR}/numpy/random/lib/*.a" |
Brad Bishop | 316dfdd | 2018-06-25 12:45:53 -0400 | [diff] [blame] | 27 | |
| 28 | # install what is needed for numpy.test() |
| 29 | RDEPENDS_${PN} = "${PYTHON_PN}-unittest \ |
| 30 | ${PYTHON_PN}-difflib \ |
| 31 | ${PYTHON_PN}-pprint \ |
| 32 | ${PYTHON_PN}-pickle \ |
| 33 | ${PYTHON_PN}-shell \ |
Brad Bishop | 316dfdd | 2018-06-25 12:45:53 -0400 | [diff] [blame] | 34 | ${PYTHON_PN}-doctest \ |
| 35 | ${PYTHON_PN}-datetime \ |
| 36 | ${PYTHON_PN}-distutils \ |
| 37 | ${PYTHON_PN}-misc \ |
| 38 | ${PYTHON_PN}-mmap \ |
| 39 | ${PYTHON_PN}-netclient \ |
| 40 | ${PYTHON_PN}-numbers \ |
| 41 | ${PYTHON_PN}-pydoc \ |
| 42 | ${PYTHON_PN}-pkgutil \ |
| 43 | ${PYTHON_PN}-email \ |
| 44 | ${PYTHON_PN}-compression \ |
| 45 | ${PYTHON_PN}-ctypes \ |
| 46 | ${PYTHON_PN}-threading \ |
Brad Bishop | 79641f2 | 2019-09-10 07:20:22 -0400 | [diff] [blame] | 47 | ${PYTHON_PN}-multiprocessing \ |
Brad Bishop | 316dfdd | 2018-06-25 12:45:53 -0400 | [diff] [blame] | 48 | " |
Andrew Geissler | 6ce62a2 | 2020-11-30 19:58:47 -0600 | [diff] [blame] | 49 | RDEPENDS_${PN}-ptest += "${PYTHON_PN}-pytest \ |
| 50 | ${PYTHON_PN}-hypothesis \ |
| 51 | ${PYTHON_PN}-sortedcontainers \ |
| 52 | ${PYTHON_PN}-resource \ |
| 53 | ldd \ |
| 54 | " |
Brad Bishop | 316dfdd | 2018-06-25 12:45:53 -0400 | [diff] [blame] | 55 | |
| 56 | RDEPENDS_${PN}_class-native = "" |
| 57 | |
| 58 | BBCLASSEXTEND = "native nativesdk" |