| HOMEPAGE = "http://github.com/openbmc/google-ipmi-sys" |
| SUMMARY = "Google Sys OEM commands" |
| DESCRIPTION = "Google sys OEM commands" |
| |
| inherit autotools pkgconfig |
| inherit obmc-phosphor-license |
| inherit systemd |
| inherit obmc-phosphor-ipmiprovider-symlink |
| |
| DEPENDS += "autoconf-archive-native" |
| DEPENDS += "sdbusplus" |
| DEPENDS += "phosphor-logging" |
| |
| # We depend on this to be built first so we can build our providers. |
| DEPENDS += "phosphor-ipmi-host" |
| |
| RDEPENDS_${PN} += "sdbusplus phosphor-dbus-interfaces" |
| |
| S = "${WORKDIR}/git" |
| SRC_URI = "git://github.com/openbmc/google-ipmi-sys" |
| SRCREV = "f9a19b80bea5987292e61b8b2aedcc3baedcaf8f" |
| |
| FILES_${PN}_append = " ${libdir}/ipmid-providers/lib*${SOLIBS}" |
| FILES_${PN}_append = " ${libdir}/host-ipmid/lib*${SOLIBS}" |
| FILES_${PN}_append = " ${libdir}/net-ipmid/lib*${SOLIBS}" |
| FILES_${PN}-dev_append = " ${libdir}/ipmid-providers/lib*${SOLIBSDEV} ${libdir}/ipmid-providers/*.la" |
| |
| HOSTIPMI_PROVIDER_LIBRARY += "libsyscmds.so" |
| |
| SYSTEMD_PACKAGES = "${PN}" |
| SYSTEMD_SERVICE_${PN} = "gbmc-psu-hardreset.target" |
| |
| do_install_append() { |
| install -d ${D}${systemd_system_unitdir} |
| install -m 0644 ${S}/gbmc-psu-hardreset.target ${D}${systemd_system_unitdir} |
| } |