Patrick Venture | 9afb671 | 2018-09-17 17:14:46 -0700 | [diff] [blame] | 1 | HOMEPAGE = "http://github.com/openbmc/google-ipmi-sys" |
| 2 | SUMMARY = "Google Sys OEM commands" |
| 3 | DESCRIPTION = "Google sys OEM commands" |
| 4 | |
| 5 | inherit autotools pkgconfig |
| 6 | inherit obmc-phosphor-license |
| 7 | inherit systemd |
| 8 | inherit obmc-phosphor-ipmiprovider-symlink |
| 9 | |
| 10 | DEPENDS += "autoconf-archive-native" |
| 11 | DEPENDS += "sdbusplus" |
| 12 | DEPENDS += "phosphor-logging" |
| 13 | |
| 14 | # We depend on this to be built first so we can build our providers. |
| 15 | DEPENDS += "phosphor-ipmi-host" |
| 16 | |
| 17 | RDEPENDS_${PN} += "sdbusplus phosphor-dbus-interfaces" |
| 18 | |
| 19 | S = "${WORKDIR}/git" |
| 20 | SRC_URI = "git://github.com/openbmc/google-ipmi-sys" |
| 21 | SRCREV = "f9a19b80bea5987292e61b8b2aedcc3baedcaf8f" |
| 22 | |
| 23 | FILES_${PN}_append = " ${libdir}/ipmid-providers/lib*${SOLIBS}" |
| 24 | FILES_${PN}_append = " ${libdir}/host-ipmid/lib*${SOLIBS}" |
| 25 | FILES_${PN}_append = " ${libdir}/net-ipmid/lib*${SOLIBS}" |
| 26 | FILES_${PN}-dev_append = " ${libdir}/ipmid-providers/lib*${SOLIBSDEV} ${libdir}/ipmid-providers/*.la" |
| 27 | |
| 28 | HOSTIPMI_PROVIDER_LIBRARY += "libsyscmds.so" |
| 29 | |
| 30 | SYSTEMD_PACKAGES = "${PN}" |
| 31 | SYSTEMD_SERVICE_${PN} = "gbmc-psu-hardreset.target" |
| 32 | |
| 33 | do_install_append() { |
| 34 | install -d ${D}${systemd_system_unitdir} |
| 35 | install -m 0644 ${S}/gbmc-psu-hardreset.target ${D}${systemd_system_unitdir} |
| 36 | } |