| SUMMARY = "WebP is an image format designed for the Web" |
| DESCRIPTION = "WebP is a method of lossy and lossless compression that can be \ |
| used on a large variety of photographic, translucent and \ |
| graphical images found on the web. The degree of lossy \ |
| compression is adjustable so a user can choose the trade-off \ |
| between file size and image quality. WebP typically achieves \ |
| an average of 30% more compression than JPEG and JPEG 2000, \ |
| without loss of image quality." |
| HOMEPAGE = "https://developers.google.com/speed/webp/" |
| SECTION = "libs" |
| |
| LICENSE = "BSD" |
| LIC_FILES_CHKSUM = "file://COPYING;md5=6e8dee932c26f2dab503abf70c96d8bb \ |
| file://PATENTS;md5=ad2580aee35468675c44d7bebba65ca8" |
| |
| SRC_URI = "http://downloads.webmproject.org/releases/webp/${BP}.tar.gz" |
| SRC_URI[md5sum] = "08813525eeeffe7e305b4cbfade8ae9b" |
| SRC_URI[sha256sum] = "efbe0d58fda936f2ed99d0b837ed7087d064d6838931f282c4618d2a3f7390c4" |
| |
| EXTRA_OECONF = " \ |
| --disable-experimental \ |
| --disable-wic \ |
| --enable-libwebpmux \ |
| --enable-libwebpdemux \ |
| --enable-threading \ |
| " |
| |
| inherit autotools lib_package |
| |
| PACKAGECONFIG ??= "" |
| |
| # libwebpdecoder is a subset of libwebp, don't build it unless requested |
| PACKAGECONFIG[decoder] = "--enable-libwebpdecoder,--disable-libwebpdecoder" |
| |
| # Apply for examples programs: cwebp and dwebp |
| PACKAGECONFIG[gif] = "--enable-gif,--disable-gif,giflib" |
| PACKAGECONFIG[jpeg] = "--enable-jpeg,--disable-jpeg,jpeg" |
| PACKAGECONFIG[png] = "--enable-png,--disable-png,,libpng" |
| PACKAGECONFIG[tiff] = "--enable-tiff,--disable-tiff,tiff" |
| |
| # Apply only for example program vwebp |
| PACKAGECONFIG[gl] = "--enable-gl,--disable-gl,mesa-glut" |
| |
| PACKAGES =+ "${PN}-gif2webp" |
| |
| DESCRIPTION_${PN}-gif2webp = "Simple tool to convert animated GIFs to WebP" |
| FILES_${PN}-gif2webp = "${bindir}/gif2webp" |