Patrick Williams | c124f4f | 2015-09-15 14:41:29 -0500 | [diff] [blame] | 1 | SUMMARY = "WebP is an image format designed for the Web" |
| 2 | DESCRIPTION = "WebP is a method of lossy and lossless compression that can be \ |
| 3 | used on a large variety of photographic, translucent and \ |
| 4 | graphical images found on the web. The degree of lossy \ |
| 5 | compression is adjustable so a user can choose the trade-off \ |
| 6 | between file size and image quality. WebP typically achieves \ |
| 7 | an average of 30% more compression than JPEG and JPEG 2000, \ |
| 8 | without loss of image quality." |
| 9 | HOMEPAGE = "https://developers.google.com/speed/webp/" |
| 10 | SECTION = "libs" |
| 11 | |
| 12 | LICENSE = "BSD" |
| 13 | LIC_FILES_CHKSUM = "file://COPYING;md5=6e8dee932c26f2dab503abf70c96d8bb \ |
| 14 | file://PATENTS;md5=ad2580aee35468675c44d7bebba65ca8" |
| 15 | |
| 16 | SRC_URI = "http://downloads.webmproject.org/releases/webp/${BP}.tar.gz" |
| 17 | SRC_URI[md5sum] = "08813525eeeffe7e305b4cbfade8ae9b" |
| 18 | SRC_URI[sha256sum] = "efbe0d58fda936f2ed99d0b837ed7087d064d6838931f282c4618d2a3f7390c4" |
| 19 | |
| 20 | EXTRA_OECONF = " \ |
| 21 | --disable-experimental \ |
| 22 | --disable-wic \ |
| 23 | --enable-libwebpmux \ |
| 24 | --enable-libwebpdemux \ |
| 25 | --enable-threading \ |
| 26 | " |
| 27 | |
| 28 | inherit autotools lib_package |
| 29 | |
| 30 | PACKAGECONFIG ??= "" |
| 31 | |
| 32 | # libwebpdecoder is a subset of libwebp, don't build it unless requested |
| 33 | PACKAGECONFIG[decoder] = "--enable-libwebpdecoder,--disable-libwebpdecoder" |
| 34 | |
| 35 | # Apply for examples programs: cwebp and dwebp |
| 36 | PACKAGECONFIG[gif] = "--enable-gif,--disable-gif,giflib" |
| 37 | PACKAGECONFIG[jpeg] = "--enable-jpeg,--disable-jpeg,jpeg" |
| 38 | PACKAGECONFIG[png] = "--enable-png,--disable-png,,libpng" |
| 39 | PACKAGECONFIG[tiff] = "--enable-tiff,--disable-tiff,tiff" |
| 40 | |
| 41 | # Apply only for example program vwebp |
| 42 | PACKAGECONFIG[gl] = "--enable-gl,--disable-gl,mesa-glut" |
| 43 | |
| 44 | PACKAGES =+ "${PN}-gif2webp" |
| 45 | |
| 46 | DESCRIPTION_${PN}-gif2webp = "Simple tool to convert animated GIFs to WebP" |
| 47 | FILES_${PN}-gif2webp = "${bindir}/gif2webp" |