| SUMMARY = "A sophisticated Numeric Processing Package for Python" |
| HOMEPAGE = "https://numpy.org/" |
| DESCRIPTION = "NumPy is the fundamental package needed for scientific computing with Python." |
| SECTION = "devel/python" |
| LICENSE = "BSD-3-Clause & BSD-2-Clause & PSF & Apache-2.0 & BSD & MIT" |
| LIC_FILES_CHKSUM = "file://LICENSE.txt;md5=aa1ecaef18152f75bfae546b29c49d3c" |
| |
| SRCNAME = "numpy" |
| |
| SRC_URI = "https://github.com/${SRCNAME}/${SRCNAME}/releases/download/v${PV}/${SRCNAME}-${PV}.tar.gz \ |
| file://0001-Don-t-search-usr-and-so-on-for-libraries-by-default-.patch \ |
| file://0001-numpy-core-Define-RISCV-32-support.patch \ |
| file://run-ptest \ |
| " |
| SRC_URI[sha256sum] = "9bf51d69ebb4ca9239e55bedc2185fe2c0ec222da0adee7ece4125414676846d" |
| |
| UPSTREAM_CHECK_URI = "https://github.com/numpy/numpy/releases" |
| UPSTREAM_CHECK_REGEX = "(?P<pver>\d+(\.\d+)+)\.tar" |
| |
| DEPENDS += "python3-cython-native" |
| |
| inherit ptest setuptools3 |
| |
| S = "${WORKDIR}/numpy-${PV}" |
| |
| CLEANBROKEN = "1" |
| |
| FILES_${PN}-staticdev += "${PYTHON_SITEPACKAGES_DIR}/numpy/core/lib/*.a ${PYTHON_SITEPACKAGES_DIR}/numpy/random/lib/*.a" |
| |
| # install what is needed for numpy.test() |
| RDEPENDS_${PN} = "${PYTHON_PN}-unittest \ |
| ${PYTHON_PN}-difflib \ |
| ${PYTHON_PN}-pprint \ |
| ${PYTHON_PN}-pickle \ |
| ${PYTHON_PN}-shell \ |
| ${PYTHON_PN}-doctest \ |
| ${PYTHON_PN}-datetime \ |
| ${PYTHON_PN}-distutils \ |
| ${PYTHON_PN}-misc \ |
| ${PYTHON_PN}-mmap \ |
| ${PYTHON_PN}-netclient \ |
| ${PYTHON_PN}-numbers \ |
| ${PYTHON_PN}-pydoc \ |
| ${PYTHON_PN}-pkgutil \ |
| ${PYTHON_PN}-email \ |
| ${PYTHON_PN}-compression \ |
| ${PYTHON_PN}-ctypes \ |
| ${PYTHON_PN}-threading \ |
| ${PYTHON_PN}-multiprocessing \ |
| " |
| RDEPENDS_${PN}-ptest += "${PYTHON_PN}-pytest \ |
| ${PYTHON_PN}-hypothesis \ |
| ${PYTHON_PN}-sortedcontainers \ |
| ${PYTHON_PN}-resource \ |
| ldd \ |
| " |
| |
| BBCLASSEXTEND = "native nativesdk" |