Brad Bishop | 316dfdd | 2018-06-25 12:45:53 -0400 | [diff] [blame] | 1 | SUMMARY = "A sophisticated Numeric Processing Package for Python" |
Andrew Geissler | 90fd73c | 2021-03-05 15:25:55 -0600 | [diff] [blame] | 2 | HOMEPAGE = "https://numpy.org/" |
| 3 | DESCRIPTION = "NumPy is the fundamental package needed for scientific computing with Python." |
Brad Bishop | 316dfdd | 2018-06-25 12:45:53 -0400 | [diff] [blame] | 4 | SECTION = "devel/python" |
Brad Bishop | 79641f2 | 2019-09-10 07:20:22 -0400 | [diff] [blame] | 5 | LICENSE = "BSD-3-Clause & BSD-2-Clause & PSF & Apache-2.0 & BSD & MIT" |
Andrew Geissler | 9b4d8b0 | 2021-02-19 12:26:16 -0600 | [diff] [blame] | 6 | LIC_FILES_CHKSUM = "file://LICENSE.txt;md5=aa1ecaef18152f75bfae546b29c49d3c" |
Brad Bishop | 316dfdd | 2018-06-25 12:45:53 -0400 | [diff] [blame] | 7 | |
| 8 | SRCNAME = "numpy" |
| 9 | |
| 10 | SRC_URI = "https://github.com/${SRCNAME}/${SRCNAME}/releases/download/v${PV}/${SRCNAME}-${PV}.tar.gz \ |
| 11 | file://0001-Don-t-search-usr-and-so-on-for-libraries-by-default-.patch \ |
Andrew Geissler | 6ce62a2 | 2020-11-30 19:58:47 -0600 | [diff] [blame] | 12 | file://0001-numpy-core-Define-RISCV-32-support.patch \ |
| 13 | file://run-ptest \ |
| 14 | " |
Andrew Geissler | 9b4d8b0 | 2021-02-19 12:26:16 -0600 | [diff] [blame] | 15 | SRC_URI[sha256sum] = "9bf51d69ebb4ca9239e55bedc2185fe2c0ec222da0adee7ece4125414676846d" |
Brad Bishop | 316dfdd | 2018-06-25 12:45:53 -0400 | [diff] [blame] | 16 | |
| 17 | UPSTREAM_CHECK_URI = "https://github.com/numpy/numpy/releases" |
| 18 | UPSTREAM_CHECK_REGEX = "(?P<pver>\d+(\.\d+)+)\.tar" |
| 19 | |
Andrew Geissler | 82c905d | 2020-04-13 13:39:40 -0500 | [diff] [blame] | 20 | DEPENDS += "python3-cython-native" |
| 21 | |
Andrew Geissler | 6ce62a2 | 2020-11-30 19:58:47 -0600 | [diff] [blame] | 22 | inherit ptest setuptools3 |
| 23 | |
Brad Bishop | 316dfdd | 2018-06-25 12:45:53 -0400 | [diff] [blame] | 24 | S = "${WORKDIR}/numpy-${PV}" |
| 25 | |
Brad Bishop | 1a4b7ee | 2018-12-16 17:11:34 -0800 | [diff] [blame] | 26 | CLEANBROKEN = "1" |
| 27 | |
Andrew Geissler | 475cb72 | 2020-07-10 16:00:51 -0500 | [diff] [blame] | 28 | FILES_${PN}-staticdev += "${PYTHON_SITEPACKAGES_DIR}/numpy/core/lib/*.a ${PYTHON_SITEPACKAGES_DIR}/numpy/random/lib/*.a" |
Brad Bishop | 316dfdd | 2018-06-25 12:45:53 -0400 | [diff] [blame] | 29 | |
| 30 | # install what is needed for numpy.test() |
| 31 | RDEPENDS_${PN} = "${PYTHON_PN}-unittest \ |
| 32 | ${PYTHON_PN}-difflib \ |
| 33 | ${PYTHON_PN}-pprint \ |
| 34 | ${PYTHON_PN}-pickle \ |
| 35 | ${PYTHON_PN}-shell \ |
Brad Bishop | 316dfdd | 2018-06-25 12:45:53 -0400 | [diff] [blame] | 36 | ${PYTHON_PN}-doctest \ |
| 37 | ${PYTHON_PN}-datetime \ |
| 38 | ${PYTHON_PN}-distutils \ |
| 39 | ${PYTHON_PN}-misc \ |
| 40 | ${PYTHON_PN}-mmap \ |
| 41 | ${PYTHON_PN}-netclient \ |
| 42 | ${PYTHON_PN}-numbers \ |
| 43 | ${PYTHON_PN}-pydoc \ |
| 44 | ${PYTHON_PN}-pkgutil \ |
| 45 | ${PYTHON_PN}-email \ |
| 46 | ${PYTHON_PN}-compression \ |
| 47 | ${PYTHON_PN}-ctypes \ |
| 48 | ${PYTHON_PN}-threading \ |
Brad Bishop | 79641f2 | 2019-09-10 07:20:22 -0400 | [diff] [blame] | 49 | ${PYTHON_PN}-multiprocessing \ |
Brad Bishop | 316dfdd | 2018-06-25 12:45:53 -0400 | [diff] [blame] | 50 | " |
Andrew Geissler | 6ce62a2 | 2020-11-30 19:58:47 -0600 | [diff] [blame] | 51 | RDEPENDS_${PN}-ptest += "${PYTHON_PN}-pytest \ |
| 52 | ${PYTHON_PN}-hypothesis \ |
| 53 | ${PYTHON_PN}-sortedcontainers \ |
| 54 | ${PYTHON_PN}-resource \ |
| 55 | ldd \ |
| 56 | " |
Brad Bishop | 316dfdd | 2018-06-25 12:45:53 -0400 | [diff] [blame] | 57 | |
Brad Bishop | 316dfdd | 2018-06-25 12:45:53 -0400 | [diff] [blame] | 58 | BBCLASSEXTEND = "native nativesdk" |