| SUMMARY = "Window navigation construction toolkit" |
| LICENSE = "LGPL-2.0-only" |
| LIC_FILES_CHKSUM = "file://COPYING;md5=5f30f0716dfdd0d91eb439ebec522ec2" |
| |
| BPN = "libwnck" |
| |
| SECTION = "x11/libs" |
| DEPENDS = "cairo glib-2.0 gtk+3" |
| |
| PACKAGECONFIG ??= "${@bb.utils.filter('DISTRO_FEATURES', 'x11', d)}" |
| PACKAGECONFIG[x11] = "-Dstartup_notification=enabled,-Dstartup_notification=disabled,startup-notification libxres" |
| |
| GNOMEBASEBUILDCLASS = "meson" |
| GTKDOC_MESON_OPTION = "gtk_doc" |
| GIR_MESON_ENABLE_FLAG = 'enabled' |
| GIR_MESON_DISABLE_FLAG = 'disabled' |
| |
| inherit gnomebase gobject-introspection gtk-doc gettext features_check |
| |
| def gnome_verdir(v): |
| return oe.utils.trim_version(v, 1) |
| |
| SRC_URI[archive.sha256sum] = "905bcdb85847d6b8f8861e56b30cd6dc61eae67ecef4cd994a9f925a26a2c1fe" |
| |
| # gtk+3 and libepoxy need to be built with x11 PACKAGECONFIG. |
| # cairo would at least needed to be built with xlib. |
| ANY_OF_DISTRO_FEATURES = "${GTK3DISTROFEATURES}" |