Andrew Geissler | 517393d | 2023-01-13 08:55:19 -0600 | [diff] [blame] | 1 | SUMMARY = "Window navigation construction toolkit" |
| 2 | LICENSE = "LGPL-2.0-only" |
| 3 | LIC_FILES_CHKSUM = "file://COPYING;md5=5f30f0716dfdd0d91eb439ebec522ec2" |
| 4 | |
| 5 | BPN = "libwnck" |
| 6 | |
| 7 | SECTION = "x11/libs" |
| 8 | DEPENDS = "cairo glib-2.0 gtk+3" |
| 9 | |
| 10 | PACKAGECONFIG ??= "${@bb.utils.filter('DISTRO_FEATURES', 'x11', d)}" |
| 11 | PACKAGECONFIG[x11] = "-Dstartup_notification=enabled,-Dstartup_notification=disabled,startup-notification libxres" |
| 12 | |
| 13 | GNOMEBASEBUILDCLASS = "meson" |
| 14 | GTKDOC_MESON_OPTION = "gtk_doc" |
| 15 | GIR_MESON_ENABLE_FLAG = 'enabled' |
| 16 | GIR_MESON_DISABLE_FLAG = 'disabled' |
| 17 | |
| 18 | inherit gnomebase gobject-introspection gtk-doc gettext features_check |
| 19 | |
| 20 | def gnome_verdir(v): |
| 21 | return oe.utils.trim_version(v, 1) |
| 22 | |
| 23 | SRC_URI[archive.sha256sum] = "905bcdb85847d6b8f8861e56b30cd6dc61eae67ecef4cd994a9f925a26a2c1fe" |
| 24 | |
| 25 | # gtk+3 and libepoxy need to be built with x11 PACKAGECONFIG. |
| 26 | # cairo would at least needed to be built with xlib. |
| 27 | ANY_OF_DISTRO_FEATURES = "${GTK3DISTROFEATURES}" |