| SUMMARY = "Style preserving TOML library" |
| HOMEPAGE = "https://pypi.org/project/tomlkit/" |
| LICENSE = "MIT" |
| LIC_FILES_CHKSUM = "file://LICENSE;md5=31aac0dbc1babd278d5386dadb7f8e82" |
| |
| SRC_URI[sha256sum] = "9330fc7faa1db67b541b28e62018c17d20be733177d290a13b24c62d1614e0c3" |
| |
| inherit pypi python_poetry_core ptest |
| |
| SRC_URI += " \ |
| file://run-ptest \ |
| " |
| |
| RDEPENDS:${PN}-ptest += " \ |
| ${PYTHON_PN}-poetry-core \ |
| ${PYTHON_PN}-pytest \ |
| ${PYTHON_PN}-pyyaml \ |
| " |
| |
| do_install_ptest() { |
| install -d ${D}${PTEST_PATH}/tests |
| cp -rf ${S}/tests/* ${D}${PTEST_PATH}/tests/ |
| } |