blob: 71a43c4551f296e87dc97ba0c114dcf3ac65c7f9 [file] [log] [blame]
Andrew Geissler3eeda902023-05-19 10:14:02 -05001SUMMARY = "Style preserving TOML library"
2HOMEPAGE = "https://pypi.org/project/tomlkit/"
3LICENSE = "MIT"
4LIC_FILES_CHKSUM = "file://LICENSE;md5=31aac0dbc1babd278d5386dadb7f8e82"
5
6SRC_URI[sha256sum] = "9330fc7faa1db67b541b28e62018c17d20be733177d290a13b24c62d1614e0c3"
7
8inherit pypi python_poetry_core ptest
9
10SRC_URI += " \
11 file://run-ptest \
12"
13
14RDEPENDS:${PN}-ptest += " \
15 ${PYTHON_PN}-poetry-core \
16 ${PYTHON_PN}-pytest \
17 ${PYTHON_PN}-pyyaml \
18"
19
20do_install_ptest() {
21 install -d ${D}${PTEST_PATH}/tests
22 cp -rf ${S}/tests/* ${D}${PTEST_PATH}/tests/
23}