| require recipes-devtools/gdb/gdb-common.inc |
| require gdb-${PV}.inc |
| require gdb-microblaze-7.7.inc |
| |
| inherit gettext |
| inherit python-dir |
| |
| PACKAGECONFIG ??= "" |
| PACKAGECONFIG[python] = "--with-python=${WORKDIR}/python,--without-python,python" |
| PACKAGECONFIG[babeltrace] = "--with-babeltrace,--without-babeltrace,babeltrace" |
| |
| do_configure_prepend() { |
| if [ -n "${@bb.utils.contains('PACKAGECONFIG', 'python', 'python', '', d)}" ]; then |
| cat > ${WORKDIR}/python << EOF |
| #!/bin/sh |
| case "\$2" in |
| --includes) echo "-I${STAGING_INCDIR}/${PYTHON_DIR}/" ;; |
| --ldflags) echo "-Wl,-rpath-link,${STAGING_LIBDIR}/.. -Wl,-rpath,${libdir}/.. -lpthread -ldl -lutil -lm -lpython${PYTHON_BASEVERSION}" ;; |
| --exec-prefix) echo "${exec_prefix}" ;; |
| *) exit 1 ;; |
| esac |
| exit 0 |
| EOF |
| chmod +x ${WORKDIR}/python |
| fi |
| } |
| |
| PACKAGES =+ "gdbserver" |
| FILES_gdbserver = "${bindir}/gdbserver" |