blob: 80b589a1f5dbeafb4772ec9043d85f88f08b42b6 [file] [log] [blame]
Brad Bishop286d45c2018-10-02 15:21:57 -04001require recipes-devtools/gdb/gdb-common.inc
2require gdb-${PV}.inc
3require gdb-microblaze-7.7.inc
4
5inherit gettext
6inherit python-dir
7
8PACKAGECONFIG ??= ""
9PACKAGECONFIG[python] = "--with-python=${WORKDIR}/python,--without-python,python"
10PACKAGECONFIG[babeltrace] = "--with-babeltrace,--without-babeltrace,babeltrace"
11
12do_configure_prepend() {
13 if [ -n "${@bb.utils.contains('PACKAGECONFIG', 'python', 'python', '', d)}" ]; then
14 cat > ${WORKDIR}/python << EOF
15#!/bin/sh
16case "\$2" in
17 --includes) echo "-I${STAGING_INCDIR}/${PYTHON_DIR}/" ;;
18 --ldflags) echo "-Wl,-rpath-link,${STAGING_LIBDIR}/.. -Wl,-rpath,${libdir}/.. -lpthread -ldl -lutil -lm -lpython${PYTHON_BASEVERSION}" ;;
19 --exec-prefix) echo "${exec_prefix}" ;;
20 *) exit 1 ;;
21esac
22exit 0
23EOF
24 chmod +x ${WORKDIR}/python
25 fi
26}
27
28PACKAGES =+ "gdbserver"
29FILES_gdbserver = "${bindir}/gdbserver"