Brad Bishop | 286d45c | 2018-10-02 15:21:57 -0400 | [diff] [blame] | 1 | require recipes-devtools/gdb/gdb-common.inc |
| 2 | require gdb-${PV}.inc |
| 3 | require gdb-microblaze-7.7.inc |
| 4 | |
| 5 | inherit gettext |
| 6 | inherit python-dir |
| 7 | |
| 8 | PACKAGECONFIG ??= "" |
| 9 | PACKAGECONFIG[python] = "--with-python=${WORKDIR}/python,--without-python,python" |
| 10 | PACKAGECONFIG[babeltrace] = "--with-babeltrace,--without-babeltrace,babeltrace" |
| 11 | |
| 12 | do_configure_prepend() { |
| 13 | if [ -n "${@bb.utils.contains('PACKAGECONFIG', 'python', 'python', '', d)}" ]; then |
| 14 | cat > ${WORKDIR}/python << EOF |
| 15 | #!/bin/sh |
| 16 | case "\$2" in |
| 17 | --includes) echo "-I${STAGING_INCDIR}/${PYTHON_DIR}/" ;; |
| 18 | --ldflags) echo "-Wl,-rpath-link,${STAGING_LIBDIR}/.. -Wl,-rpath,${libdir}/.. -lpthread -ldl -lutil -lm -lpython${PYTHON_BASEVERSION}" ;; |
| 19 | --exec-prefix) echo "${exec_prefix}" ;; |
| 20 | *) exit 1 ;; |
| 21 | esac |
| 22 | exit 0 |
| 23 | EOF |
| 24 | chmod +x ${WORKDIR}/python |
| 25 | fi |
| 26 | } |
| 27 | |
| 28 | PACKAGES =+ "gdbserver" |
| 29 | FILES_gdbserver = "${bindir}/gdbserver" |