| SUMMARY = "Generic font configuration library" |
| DESCRIPTION = "Fontconfig is a font configuration and customization library, which \ |
| does not depend on the X Window System. It is designed to locate \ |
| fonts within the system and select them according to requirements \ |
| specified by applications. \ |
| Fontconfig is not a rasterization library, nor does it impose a \ |
| particular rasterization library on the application. The X-specific \ |
| library 'Xft' uses fontconfig along with freetype to specify and \ |
| rasterize fonts." |
| |
| HOMEPAGE = "http://www.fontconfig.org" |
| BUGTRACKER = "https://bugs.freedesktop.org/enter_bug.cgi?product=fontconfig" |
| |
| LICENSE = "MIT-style & MIT & PD" |
| LIC_FILES_CHKSUM = "file://COPYING;md5=7a0449e9bc5370402a94c00204beca3d \ |
| file://src/fcfreetype.c;endline=45;md5=5d9513e3196a1fbfdfa94051c09dfc84 \ |
| file://src/fccache.c;beginline=1199;endline=1214;md5=0326cfeb4a7333dd4dd25fbbc4b9f27f" |
| |
| SECTION = "libs" |
| |
| DEPENDS = "expat freetype zlib" |
| |
| SRC_URI = "http://fontconfig.org/release/fontconfig-${PV}.tar.gz \ |
| file://revert-static-pkgconfig.patch \ |
| " |
| SRC_URI[md5sum] = "479be870c7f83f15f87bac085b61d641" |
| SRC_URI[sha256sum] = "73f6d323c7bcfbde25d78397675191d55b8f4139132c6a9444410f3a2d8a9a95" |
| |
| PACKAGES =+ "fontconfig-utils" |
| FILES_${PN} =+ "${datadir}/xml/*" |
| FILES_fontconfig-utils = "${bindir}/*" |
| |
| # Work around past breakage in debian.bbclass |
| RPROVIDES_fontconfig-utils = "libfontconfig-utils" |
| RREPLACES_fontconfig-utils = "libfontconfig-utils" |
| RCONFLICTS_fontconfig-utils = "libfontconfig-utils" |
| DEBIAN_NOAUTONAME_fontconfig-utils = "1" |
| |
| inherit autotools pkgconfig |
| |
| FONTCONFIG_CACHE_DIR ?= "${localstatedir}/cache/fontconfig" |
| |
| EXTRA_OECONF = " --disable-docs --with-default-fonts=${datadir}/fonts --with-cache-dir=${FONTCONFIG_CACHE_DIR}" |
| |
| BBCLASSEXTEND = "native" |