Patrick Williams | c124f4f | 2015-09-15 14:41:29 -0500 | [diff] [blame] | 1 | SUMMARY = "Generic font configuration library" |
| 2 | DESCRIPTION = "Fontconfig is a font configuration and customization library, which \ |
| 3 | does not depend on the X Window System. It is designed to locate \ |
| 4 | fonts within the system and select them according to requirements \ |
| 5 | specified by applications. \ |
| 6 | Fontconfig is not a rasterization library, nor does it impose a \ |
| 7 | particular rasterization library on the application. The X-specific \ |
| 8 | library 'Xft' uses fontconfig along with freetype to specify and \ |
| 9 | rasterize fonts." |
| 10 | |
| 11 | HOMEPAGE = "http://www.fontconfig.org" |
| 12 | BUGTRACKER = "https://bugs.freedesktop.org/enter_bug.cgi?product=fontconfig" |
| 13 | |
| 14 | LICENSE = "MIT-style & MIT & PD" |
| 15 | LIC_FILES_CHKSUM = "file://COPYING;md5=7a0449e9bc5370402a94c00204beca3d \ |
| 16 | file://src/fcfreetype.c;endline=45;md5=5d9513e3196a1fbfdfa94051c09dfc84 \ |
| 17 | file://src/fccache.c;beginline=1199;endline=1214;md5=0326cfeb4a7333dd4dd25fbbc4b9f27f" |
| 18 | |
| 19 | SECTION = "libs" |
| 20 | |
| 21 | DEPENDS = "expat freetype zlib" |
| 22 | |
| 23 | SRC_URI = "http://fontconfig.org/release/fontconfig-${PV}.tar.gz \ |
| 24 | file://revert-static-pkgconfig.patch \ |
| 25 | " |
| 26 | SRC_URI[md5sum] = "479be870c7f83f15f87bac085b61d641" |
| 27 | SRC_URI[sha256sum] = "73f6d323c7bcfbde25d78397675191d55b8f4139132c6a9444410f3a2d8a9a95" |
| 28 | |
| 29 | PACKAGES =+ "fontconfig-utils" |
| 30 | FILES_${PN} =+ "${datadir}/xml/*" |
| 31 | FILES_fontconfig-utils = "${bindir}/*" |
| 32 | |
| 33 | # Work around past breakage in debian.bbclass |
| 34 | RPROVIDES_fontconfig-utils = "libfontconfig-utils" |
| 35 | RREPLACES_fontconfig-utils = "libfontconfig-utils" |
| 36 | RCONFLICTS_fontconfig-utils = "libfontconfig-utils" |
| 37 | DEBIAN_NOAUTONAME_fontconfig-utils = "1" |
| 38 | |
| 39 | inherit autotools pkgconfig |
| 40 | |
| 41 | FONTCONFIG_CACHE_DIR ?= "${localstatedir}/cache/fontconfig" |
| 42 | |
| 43 | EXTRA_OECONF = " --disable-docs --with-default-fonts=${datadir}/fonts --with-cache-dir=${FONTCONFIG_CACHE_DIR}" |
| 44 | |
| 45 | BBCLASSEXTEND = "native" |