blob: 466f42f0bd3e8b477b8d72ce3ab5b91d073487c5 [file] [log] [blame]
Alexander Filippov000c8ff2020-06-10 17:55:57 +03001FILESEXTRAPATHS_prepend := "${THISDIR}/${PN}:"
2
3inherit systemd
4
5RDEPENDS_${PN} = "${VIRTUAL-RUNTIME_base-utils}"
6SYSTEMD_SERVICE_${PN} = "${BPN}.service"
7SRC_URI_append = " \
8 file://${BPN}-set-device-id.sh \
9 file://${BPN}.service \
10"
11
12S = "${WORKDIR}"
13do_install_append() {
14 install -d ${D}${bindir} ${D}${systemd_system_unitdir}
15 install ${BPN}-set-device-id.sh ${D}${bindir}/
16 install -m 0644 ${BPN}.service ${D}${systemd_system_unitdir}/
17}
18
19FILES_${PN}_append = " \
20 ${bindir}/${BPN}-set-device-id.sh \
21"