Brad Bishop | 1932369 | 2019-04-05 15:28:33 -0400 | [diff] [blame] | 1 | SUMMARY = "Debugging and profiling extension for PHP" |
| 2 | LICENSE = "Xdebug" |
| 3 | LIC_FILES_CHKSUM = "file://LICENSE;md5=92d94a330d34ee6edc2638450736f119" |
| 4 | |
| 5 | DEPENDS = "php re2c-native" |
| 6 | |
| 7 | SRC_URI = "http://xdebug.org/files/xdebug-${PV}.tgz" |
| 8 | |
Brad Bishop | 15ae250 | 2019-06-18 21:44:24 -0400 | [diff] [blame] | 9 | SRC_URI[md5sum] = "5d1a8ca3101df93938d283933f256493" |
| 10 | SRC_URI[sha256sum] = "b0f3283aa185c23fcd0137c3aaa58554d330995ef7a3421e983e8d018b05a4a6" |
Brad Bishop | 1932369 | 2019-04-05 15:28:33 -0400 | [diff] [blame] | 11 | |
| 12 | UPSTREAM_CHECK_REGEX = "xdebug-(?P<pver>\d+(\.\d+)+)\.tgz" |
| 13 | |
| 14 | inherit autotools |
| 15 | |
| 16 | EXTRA_OECONF += "--enable-xdebug -with-php-config=${STAGING_BINDIR_CROSS}/php-config" |
| 17 | |
| 18 | do_configure() { |
| 19 | cd ${S} |
| 20 | ${STAGING_BINDIR_CROSS}/phpize |
| 21 | cd ${B} |
| 22 | |
| 23 | # Running autoreconf as autotools_do_configure would do here |
| 24 | # breaks the libtool configuration resulting in a failure later |
| 25 | # in do_compile. It's possible this may be fixable, however the |
| 26 | # easiest course of action for the moment is to avoid doing that. |
| 27 | oe_runconf |
| 28 | } |
| 29 | |
| 30 | do_install() { |
| 31 | oe_runmake install INSTALL_ROOT=${D} |
| 32 | } |
| 33 | |
| 34 | FILES_${PN} += "${libdir}/php*/extensions/*/*.so" |
| 35 | FILES_${PN}-dbg += "${libdir}/php*/extensions/*/.debug" |