Brad Bishop | e42b3e3 | 2020-01-15 22:08:42 -0500 | [diff] [blame] | 1 | SUMMARY = "The network configuration abstraction renderer" |
| 2 | DESCRIPTION = "Netplan is a utility for easily configuring networking on a \ |
| 3 | linux system. You simply create a YAML description of the required network \ |
| 4 | interfaces and what each should be configured to do. From this description \ |
| 5 | Netplan will generate all the necessary configuration for your chosen renderer \ |
| 6 | tool." |
| 7 | HOMEPAGE = "https://netplan.io" |
| 8 | SECTION = "net/misc" |
| 9 | |
| 10 | LICENSE = "GPLv3" |
| 11 | LIC_FILES_CHKSUM = "file://COPYING;md5=d32239bcb673463ab874e80d47fae504" |
| 12 | |
| 13 | S = "${WORKDIR}/git" |
Andrew Geissler | d159c7f | 2021-09-02 21:05:58 -0500 | [diff] [blame] | 14 | SRCREV = "51c872d856db80281ea810ebc02e05c09d5310fa" |
| 15 | PV = "0.103" |
Brad Bishop | e42b3e3 | 2020-01-15 22:08:42 -0500 | [diff] [blame] | 16 | |
Andrew Geissler | d159c7f | 2021-09-02 21:05:58 -0500 | [diff] [blame] | 17 | SRC_URI = "git://github.com/CanonicalLtd/netplan.git;branch=main \ |
| 18 | file://0001-parse-nm-fix-32bit-format-string.patch" |
| 19 | |
Patrick Williams | 213cb26 | 2021-08-07 19:21:33 -0500 | [diff] [blame] | 20 | SRC_URI:append:libc-musl = " file://0001-don-t-fail-if-GLOB_BRACE-is-not-defined.patch" |
Brad Bishop | e42b3e3 | 2020-01-15 22:08:42 -0500 | [diff] [blame] | 21 | |
Andrew Geissler | 2ee498a | 2020-05-29 15:52:06 -0500 | [diff] [blame] | 22 | DEPENDS = "glib-2.0 libyaml ${@bb.utils.filter('DISTRO_FEATURES', 'systemd', d)}" |
| 23 | |
Patrick Williams | 213cb26 | 2021-08-07 19:21:33 -0500 | [diff] [blame] | 24 | RDEPENDS:${PN} = "python3 python3-core python3-pyyaml python3-netifaces python3-nose python3-coverage python3-pycodestyle python3-pyflakes util-linux-libuuid libnetplan" |
Brad Bishop | e42b3e3 | 2020-01-15 22:08:42 -0500 | [diff] [blame] | 25 | |
| 26 | inherit pkgconfig systemd |
| 27 | |
| 28 | TARGET_CC_ARCH += "${LDFLAGS}" |
| 29 | |
Andrew Geissler | d221e03 | 2020-07-10 16:13:21 -0500 | [diff] [blame] | 30 | EXTRA_OEMAKE = "generate netplan/_features.py" |
Brad Bishop | e42b3e3 | 2020-01-15 22:08:42 -0500 | [diff] [blame] | 31 | EXTRA_OEMAKE =+ "${@bb.utils.contains('DISTRO_FEATURES','systemd','netplan-dbus dbus/io.netplan.Netplan.service','',d)}" |
| 32 | |
| 33 | do_install() { |
Andrew Geissler | d221e03 | 2020-07-10 16:13:21 -0500 | [diff] [blame] | 34 | install -d ${D}${sbindir} ${D}${libdir} ${D}${base_libdir}/netplan ${D}${datadir}/netplan/netplan/cli/commands ${D}${sysconfdir}/netplan |
Brad Bishop | e42b3e3 | 2020-01-15 22:08:42 -0500 | [diff] [blame] | 35 | install -m 755 ${S}/generate ${D}${base_libdir}/netplan/ |
| 36 | install -m 644 ${S}/netplan/*.py ${D}${datadir}/netplan/netplan |
| 37 | install -m 644 ${S}/netplan/cli/*.py ${D}${datadir}/netplan/netplan/cli |
| 38 | install -m 644 ${S}/netplan/cli/commands/*.py ${D}${datadir}/netplan/netplan/cli/commands |
| 39 | install -m 755 ${S}/src/netplan.script ${D}${datadir}/netplan/ |
| 40 | ln -srf ${D}${datadir}/netplan/netplan.script ${D}${sbindir}/netplan |
| 41 | |
| 42 | install -d ${D}/${systemd_unitdir}/system ${D}${systemd_unitdir}/system-generators |
Brad Bishop | e42b3e3 | 2020-01-15 22:08:42 -0500 | [diff] [blame] | 43 | ln -srf ${D}/${base_libdir}/netplan/generate ${D}${systemd_unitdir}/system-generators |
| 44 | |
| 45 | if ${@bb.utils.contains('DISTRO_FEATURES','systemd','true','false',d)}; then |
| 46 | install -d ${D}${datadir}/dbus-1/system.d ${D}${datadir}/dbus-1/system-services |
| 47 | install -m 755 ${S}/netplan-dbus ${D}${base_libdir}/netplan |
| 48 | install -m 644 ${S}/dbus/io.netplan.Netplan.conf ${D}${datadir}/dbus-1/system.d |
| 49 | install -m 644 ${S}/dbus/io.netplan.Netplan.service ${D}${datadir}/dbus-1/system-services |
| 50 | fi |
Andrew Geissler | d221e03 | 2020-07-10 16:13:21 -0500 | [diff] [blame] | 51 | |
| 52 | install -m 755 ${S}/libnetplan.so.0.0 ${D}${libdir} |
| 53 | ln -rfs ${D}${libdir}/libnetplan.so.0.0 ${D}${libdir}/libnetplan.so |
Brad Bishop | e42b3e3 | 2020-01-15 22:08:42 -0500 | [diff] [blame] | 54 | } |
| 55 | |
Andrew Geissler | d221e03 | 2020-07-10 16:13:21 -0500 | [diff] [blame] | 56 | PACKAGES += "${PN}-dbus libnetplan" |
Brad Bishop | e42b3e3 | 2020-01-15 22:08:42 -0500 | [diff] [blame] | 57 | |
Patrick Williams | 213cb26 | 2021-08-07 19:21:33 -0500 | [diff] [blame] | 58 | FILES:libnetplan = "${libdir}/libnetplan.so.0.0" |
| 59 | FILES:${PN} = "${sbindir} ${base_libdir}/netplan/generate ${datadir}/netplan ${sysconfdir}/netplan ${systemd_unitdir}" |
| 60 | FILES:${PN}-dbus = "${base_libdir}/netplan/netplan-dbus ${datadir}/dbus-1" |