Patrick Williams | 169d7bc | 2024-01-05 11:33:25 -0600 | [diff] [blame] | 1 | SUMMARY = "Parse strings using a specification based on the Python format() syntax" |
| 2 | HOMEPAGE = "https://github.com/r1chardj0n3s/parse" |
| 3 | LICENSE = "MIT" |
| 4 | LIC_FILES_CHKSUM = "file://LICENSE;md5=8ab458ad281b60e6f1b39b3feafbfc05" |
| 5 | |
Patrick Williams | 73bd93f | 2024-02-20 08:07:48 -0600 | [diff] [blame] | 6 | SRC_URI[sha256sum] = "09002ca350ad42e76629995f71f7b518670bcf93548bdde3684fd55d2be51975" |
Patrick Williams | 169d7bc | 2024-01-05 11:33:25 -0600 | [diff] [blame] | 7 | |
| 8 | SRC_URI += " \ |
| 9 | file://run-ptest \ |
| 10 | " |
| 11 | |
| 12 | inherit pypi python_setuptools_build_meta ptest |
| 13 | |
| 14 | RDEPENDS:${PN} += "\ |
| 15 | python3-datetime \ |
| 16 | python3-logging \ |
| 17 | python3-numbers \ |
| 18 | " |
| 19 | |
| 20 | RDEPENDS:${PN}-ptest += " \ |
| 21 | python3-pytest \ |
Patrick Williams | 3965356 | 2024-03-01 08:54:02 -0600 | [diff] [blame] | 22 | python3-unittest-automake-output \ |
Patrick Williams | 169d7bc | 2024-01-05 11:33:25 -0600 | [diff] [blame] | 23 | " |
| 24 | |
| 25 | do_install_ptest() { |
| 26 | cp -f ${S}/tests/test*.py ${D}${PTEST_PATH}/ |
| 27 | } |