blob: d2b91b3f30812443696fa2f30d1a7a3a6025bba8 [file] [log] [blame]
Patrick Williams169d7bc2024-01-05 11:33:25 -06001SUMMARY = "Parse strings using a specification based on the Python format() syntax"
2HOMEPAGE = "https://github.com/r1chardj0n3s/parse"
3LICENSE = "MIT"
4LIC_FILES_CHKSUM = "file://LICENSE;md5=8ab458ad281b60e6f1b39b3feafbfc05"
5
Patrick Williams73bd93f2024-02-20 08:07:48 -06006SRC_URI[sha256sum] = "09002ca350ad42e76629995f71f7b518670bcf93548bdde3684fd55d2be51975"
Patrick Williams169d7bc2024-01-05 11:33:25 -06007
8SRC_URI += " \
9 file://run-ptest \
10"
11
12inherit pypi python_setuptools_build_meta ptest
13
14RDEPENDS:${PN} += "\
15 python3-datetime \
16 python3-logging \
17 python3-numbers \
18"
19
20RDEPENDS:${PN}-ptest += " \
21 python3-pytest \
Patrick Williams39653562024-03-01 08:54:02 -060022 python3-unittest-automake-output \
Patrick Williams169d7bc2024-01-05 11:33:25 -060023"
24
25do_install_ptest() {
26 cp -f ${S}/tests/test*.py ${D}${PTEST_PATH}/
27}