Patrick Williams | ac13d5f | 2023-11-24 18:59:46 -0600 | [diff] [blame] | 1 | SUMMARY = "Python Imaging Library (Fork). Pillow is the friendly PIL fork by Alex \ |
| 2 | Clark and Contributors. PIL is the Python Imaging Library by Fredrik Lundh and \ |
| 3 | Contributors." |
| 4 | HOMEPAGE = "https://pillow.readthedocs.io" |
| 5 | LICENSE = "MIT" |
Patrick Williams | 44b3caf | 2024-04-12 16:51:14 -0500 | [diff] [blame] | 6 | LIC_FILES_CHKSUM = "file://LICENSE;md5=c349a4b4b9ec2377a8fd6a7df87dbffe" |
Patrick Williams | ac13d5f | 2023-11-24 18:59:46 -0600 | [diff] [blame] | 7 | |
Patrick Williams | f52e3dd | 2024-01-26 13:04:43 -0600 | [diff] [blame] | 8 | SRC_URI = "git://github.com/python-pillow/Pillow.git;branch=main;protocol=https \ |
Patrick Williams | ac13d5f | 2023-11-24 18:59:46 -0600 | [diff] [blame] | 9 | file://0001-support-cross-compiling.patch \ |
Patrick Williams | ac13d5f | 2023-11-24 18:59:46 -0600 | [diff] [blame] | 10 | file://run-ptest \ |
| 11 | " |
Patrick Williams | 44b3caf | 2024-04-12 16:51:14 -0500 | [diff] [blame] | 12 | SRCREV = "5c89d88eee199ba53f64581ea39b6a1bc52feb1a" |
Patrick Williams | ac13d5f | 2023-11-24 18:59:46 -0600 | [diff] [blame] | 13 | |
Patrick Williams | 44b3caf | 2024-04-12 16:51:14 -0500 | [diff] [blame] | 14 | inherit python_setuptools_build_meta ptest |
| 15 | |
| 16 | PEP517_BUILD_OPTS += " \ |
| 17 | -C platform-guessing=disable \ |
| 18 | -C zlib=enable \ |
| 19 | -C jpeg=enable \ |
| 20 | -C tiff=enable \ |
| 21 | -C freetype=enable \ |
| 22 | -C lcms=enable \ |
| 23 | -C jpeg2000=enable \ |
| 24 | -C webp=disable \ |
| 25 | -C webpmux=disable \ |
| 26 | -C imagequant=disable \ |
| 27 | " |
Patrick Williams | ac13d5f | 2023-11-24 18:59:46 -0600 | [diff] [blame] | 28 | |
Patrick Williams | ac13d5f | 2023-11-24 18:59:46 -0600 | [diff] [blame] | 29 | DEPENDS += " \ |
| 30 | zlib \ |
| 31 | jpeg \ |
| 32 | tiff \ |
| 33 | freetype \ |
| 34 | lcms \ |
| 35 | openjpeg \ |
| 36 | " |
| 37 | |
| 38 | RDEPENDS:${PN} += " \ |
Patrick Williams | 73bd93f | 2024-02-20 08:07:48 -0600 | [diff] [blame] | 39 | python3-misc \ |
| 40 | python3-logging \ |
| 41 | python3-numbers \ |
Patrick Williams | ac13d5f | 2023-11-24 18:59:46 -0600 | [diff] [blame] | 42 | ${@bb.utils.contains('DISTRO_FEATURES', 'x11', 'libxcb', '', d)} \ |
| 43 | " |
| 44 | |
| 45 | RDEPENDS:${PN}-ptest += " \ |
| 46 | bash \ |
| 47 | ghostscript \ |
| 48 | jpeg-tools \ |
| 49 | libwebp \ |
Patrick Williams | 73bd93f | 2024-02-20 08:07:48 -0600 | [diff] [blame] | 50 | python3-core \ |
| 51 | python3-image \ |
| 52 | python3-mmap \ |
| 53 | python3-pytest \ |
| 54 | python3-pytest-timeout \ |
| 55 | python3-resource \ |
| 56 | python3-unittest-automake-output \ |
| 57 | python3-unixadmin\ |
Patrick Williams | ac13d5f | 2023-11-24 18:59:46 -0600 | [diff] [blame] | 58 | ${@bb.utils.contains('DISTRO_FEATURES', 'x11', 'tk', '', d)} \ |
| 59 | " |
| 60 | |
| 61 | CVE_PRODUCT = "pillow" |
| 62 | |
| 63 | S = "${WORKDIR}/git" |
| 64 | |
| 65 | RPROVIDES:${PN} += "python3-imaging" |
| 66 | |
| 67 | do_install_ptest() { |
Patrick Williams | 44b3caf | 2024-04-12 16:51:14 -0500 | [diff] [blame] | 68 | install -d ${D}${PTEST_PATH}/Tests |
| 69 | cp -rf ${S}/Tests ${D}${PTEST_PATH}/ |
Patrick Williams | ac13d5f | 2023-11-24 18:59:46 -0600 | [diff] [blame] | 70 | } |
| 71 | |
| 72 | BBCLASSEXTEND = "native" |