blob: debf488154b1ac76b79f082b2f9a961897a656d7 [file] [log] [blame]
Patrick Williamsac13d5f2023-11-24 18:59:46 -06001SUMMARY = "Python Imaging Library (Fork). Pillow is the friendly PIL fork by Alex \
2Clark and Contributors. PIL is the Python Imaging Library by Fredrik Lundh and \
3Contributors."
4HOMEPAGE = "https://pillow.readthedocs.io"
5LICENSE = "MIT"
Patrick Williams44b3caf2024-04-12 16:51:14 -05006LIC_FILES_CHKSUM = "file://LICENSE;md5=c349a4b4b9ec2377a8fd6a7df87dbffe"
Patrick Williamsac13d5f2023-11-24 18:59:46 -06007
Patrick Williamsf52e3dd2024-01-26 13:04:43 -06008SRC_URI = "git://github.com/python-pillow/Pillow.git;branch=main;protocol=https \
Patrick Williamsac13d5f2023-11-24 18:59:46 -06009 file://0001-support-cross-compiling.patch \
Patrick Williamsac13d5f2023-11-24 18:59:46 -060010 file://run-ptest \
11 "
Patrick Williams44b3caf2024-04-12 16:51:14 -050012SRCREV = "5c89d88eee199ba53f64581ea39b6a1bc52feb1a"
Patrick Williamsac13d5f2023-11-24 18:59:46 -060013
Patrick Williams44b3caf2024-04-12 16:51:14 -050014inherit python_setuptools_build_meta ptest
15
16PEP517_BUILD_OPTS += " \
17 -C platform-guessing=disable \
18 -C zlib=enable \
19 -C jpeg=enable \
20 -C tiff=enable \
21 -C freetype=enable \
22 -C lcms=enable \
23 -C jpeg2000=enable \
24 -C webp=disable \
25 -C webpmux=disable \
26 -C imagequant=disable \
27"
Patrick Williamsac13d5f2023-11-24 18:59:46 -060028
Patrick Williamsac13d5f2023-11-24 18:59:46 -060029DEPENDS += " \
30 zlib \
31 jpeg \
32 tiff \
33 freetype \
34 lcms \
35 openjpeg \
36"
37
38RDEPENDS:${PN} += " \
Patrick Williams73bd93f2024-02-20 08:07:48 -060039 python3-misc \
40 python3-logging \
41 python3-numbers \
Patrick Williamsac13d5f2023-11-24 18:59:46 -060042 ${@bb.utils.contains('DISTRO_FEATURES', 'x11', 'libxcb', '', d)} \
43"
44
45RDEPENDS:${PN}-ptest += " \
46 bash \
47 ghostscript \
48 jpeg-tools \
49 libwebp \
Patrick Williams73bd93f2024-02-20 08:07:48 -060050 python3-core \
51 python3-image \
52 python3-mmap \
53 python3-pytest \
54 python3-pytest-timeout \
55 python3-resource \
56 python3-unittest-automake-output \
57 python3-unixadmin\
Patrick Williamsac13d5f2023-11-24 18:59:46 -060058 ${@bb.utils.contains('DISTRO_FEATURES', 'x11', 'tk', '', d)} \
59"
60
61CVE_PRODUCT = "pillow"
62
63S = "${WORKDIR}/git"
64
65RPROVIDES:${PN} += "python3-imaging"
66
67do_install_ptest() {
Patrick Williams44b3caf2024-04-12 16:51:14 -050068 install -d ${D}${PTEST_PATH}/Tests
69 cp -rf ${S}/Tests ${D}${PTEST_PATH}/
Patrick Williamsac13d5f2023-11-24 18:59:46 -060070}
71
72BBCLASSEXTEND = "native"