blob: 93fa645f33073dec196e4502029ae228e856ebe8 [file] [log] [blame]
Patrick Williams8e7b46e2023-05-01 14:19:06 -05001SUMMARY = "Modern password hashing for your software and your servers."
Andrew Geissler9aee5002022-03-30 16:27:02 +00002LICENSE = "Apache-2.0"
3LIC_FILES_CHKSUM = "file://LICENSE;md5=8f7bb094c7232b058c7e9f2e431f389c"
4HOMEPAGE = "https://pypi.org/project/bcrypt/"
5
Patrick Williams73bd93f2024-02-20 08:07:48 -06006DEPENDS += "python3-cffi-native"
Patrick Williams520786c2023-06-25 16:20:36 -05007LDFLAGS:append = "${@bb.utils.contains('DISTRO_FEATURES', 'ptest', ' -fuse-ld=bfd', '', d)}"
Andrew Geissler9aee5002022-03-30 16:27:02 +00008
Patrick Williams705982a2024-01-12 09:51:57 -06009SRC_URI[sha256sum] = "33313a1200a3ae90b75587ceac502b048b840fc69e7f7a0905b5f87fac7a1258"
Andrew Geissler9aee5002022-03-30 16:27:02 +000010
Andrew Geissler028142b2023-05-05 11:29:21 -050011inherit pypi python_setuptools3_rust ptest-cargo cargo-update-recipe-crates
Andrew Geissler9aee5002022-03-30 16:27:02 +000012
13SRC_URI += " \
Patrick Williams39653562024-03-01 08:54:02 -060014 file://0001-Bump-pyo3-from-0.20.0-to-0.20.3-in-src-_bcrypt-746.patch \
Andrew Geissler9aee5002022-03-30 16:27:02 +000015 file://run-ptest \
16"
17
Andrew Geissler028142b2023-05-05 11:29:21 -050018CARGO_SRC_DIR = "src/_bcrypt"
19
Patrick Williams2390b1b2022-11-03 13:47:49 -050020require ${BPN}-crates.inc
21
Andrew Geissler9aee5002022-03-30 16:27:02 +000022RDEPENDS:${PN}-ptest += " \
Patrick Williams73bd93f2024-02-20 08:07:48 -060023 python3-pytest \
24 python3-unittest-automake-output \
Andrew Geissler9aee5002022-03-30 16:27:02 +000025"
26
27do_install_ptest() {
28 install -d ${D}${PTEST_PATH}/tests
29 cp -rf ${S}/tests/* ${D}${PTEST_PATH}/tests/
30}
31
32RDEPENDS:${PN}:class-target += "\
Patrick Williams73bd93f2024-02-20 08:07:48 -060033 python3-cffi \
34 python3-ctypes \
35 python3-shell \
36 python3-six \
Andrew Geissler9aee5002022-03-30 16:27:02 +000037"