Brad Bishop | 1a4b7ee | 2018-12-16 17:11:34 -0800 | [diff] [blame] | 1 | SUMMARY = "File synchronization tool" |
| 2 | HOMEPAGE = "http://rsync.samba.org/" |
| 3 | BUGTRACKER = "http://rsync.samba.org/bugzilla.html" |
| 4 | SECTION = "console/network" |
Brad Bishop | 316dfdd | 2018-06-25 12:45:53 -0400 | [diff] [blame] | 5 | # GPLv2+ (<< 3.0.0), GPLv3+ (>= 3.0.0) |
| 6 | LICENSE = "GPLv3+" |
| 7 | LIC_FILES_CHKSUM = "file://COPYING;md5=d32239bcb673463ab874e80d47fae504" |
| 8 | |
Brad Bishop | 1a4b7ee | 2018-12-16 17:11:34 -0800 | [diff] [blame] | 9 | DEPENDS = "popt" |
| 10 | |
| 11 | SRC_URI = "https://download.samba.org/pub/${BPN}/src/${BP}.tar.gz \ |
| 12 | file://rsyncd.conf \ |
| 13 | file://makefile-no-rebuild.patch \ |
Brad Bishop | 96ff198 | 2019-08-19 13:50:42 -0400 | [diff] [blame] | 14 | file://CVE-2016-9840.patch \ |
| 15 | file://CVE-2016-9841.patch \ |
| 16 | file://CVE-2016-9842.patch \ |
| 17 | file://CVE-2016-9843.patch \ |
Brad Bishop | 1a4b7ee | 2018-12-16 17:11:34 -0800 | [diff] [blame] | 18 | " |
| 19 | |
| 20 | SRC_URI[md5sum] = "1581a588fde9d89f6bc6201e8129afaf" |
| 21 | SRC_URI[sha256sum] = "55cc554efec5fdaad70de921cd5a5eeb6c29a95524c715f3bbf849235b0800c0" |
| 22 | |
Andrew Geissler | 82c905d | 2020-04-13 13:39:40 -0500 | [diff] [blame] | 23 | # -16548 required for v3.1.3pre1. Already in v3.1.3. |
| 24 | CVE_CHECK_WHITELIST += " CVE-2017-16548 " |
| 25 | |
Brad Bishop | 1a4b7ee | 2018-12-16 17:11:34 -0800 | [diff] [blame] | 26 | inherit autotools |
| 27 | |
Brad Bishop | 316dfdd | 2018-06-25 12:45:53 -0400 | [diff] [blame] | 28 | PACKAGECONFIG ??= "acl attr \ |
| 29 | ${@bb.utils.filter('DISTRO_FEATURES', 'ipv6', d)} \ |
| 30 | " |
Brad Bishop | 1a4b7ee | 2018-12-16 17:11:34 -0800 | [diff] [blame] | 31 | |
Brad Bishop | 316dfdd | 2018-06-25 12:45:53 -0400 | [diff] [blame] | 32 | PACKAGECONFIG[acl] = "--enable-acl-support,--disable-acl-support,acl," |
| 33 | PACKAGECONFIG[attr] = "--enable-xattr-support,--disable-xattr-support,attr," |
Brad Bishop | 1a4b7ee | 2018-12-16 17:11:34 -0800 | [diff] [blame] | 34 | PACKAGECONFIG[ipv6] = "--enable-ipv6,--disable-ipv6," |
Brad Bishop | 316dfdd | 2018-06-25 12:45:53 -0400 | [diff] [blame] | 35 | |
| 36 | # By default, if crosscompiling, rsync disables a number of |
| 37 | # capabilities, hardlinking symlinks and special files (i.e. devices) |
| 38 | CACHED_CONFIGUREVARS += "rsync_cv_can_hardlink_special=yes rsync_cv_can_hardlink_symlink=yes" |
| 39 | |
Brad Bishop | 1a4b7ee | 2018-12-16 17:11:34 -0800 | [diff] [blame] | 40 | EXTRA_OEMAKE = 'STRIP=""' |
| 41 | |
Brad Bishop | 316dfdd | 2018-06-25 12:45:53 -0400 | [diff] [blame] | 42 | # rsync 3.0 uses configure.sh instead of configure, and |
| 43 | # makefile checks the existence of configure.sh |
| 44 | do_configure_prepend () { |
| 45 | rm -f ${S}/configure ${S}/configure.sh |
| 46 | } |
| 47 | |
| 48 | do_configure_append () { |
| 49 | cp -f ${S}/configure ${S}/configure.sh |
| 50 | } |
| 51 | |
Brad Bishop | 1a4b7ee | 2018-12-16 17:11:34 -0800 | [diff] [blame] | 52 | do_install_append() { |
| 53 | install -d ${D}${sysconfdir} |
| 54 | install -m 0644 ${WORKDIR}/rsyncd.conf ${D}${sysconfdir} |
| 55 | } |
| 56 | |
Brad Bishop | 316dfdd | 2018-06-25 12:45:53 -0400 | [diff] [blame] | 57 | BBCLASSEXTEND = "native" |