Lancelot Kao | 4357d53 | 2021-02-22 15:20:35 -0600 | [diff] [blame] | 1 | SUMMARY = "Phosphor OpenBMC Kudo BIOS Firmware Upgrade Command" |
| 2 | DESCRIPTION = "Phosphor OpenBMC Kudo BIOS Firmware Upgrade Comman Daemon" |
| 3 | |
| 4 | PR = "r1" |
| 5 | LICENSE = "Apache-2.0" |
| 6 | LIC_FILES_CHKSUM = "file://${COREBASE}/meta/files/common-licenses/Apache-2.0;md5=89aea4e17d99a7cacdbeed46a0096b10" |
| 7 | |
| 8 | inherit systemd |
| 9 | inherit obmc-phosphor-systemd |
| 10 | |
| 11 | DEPENDS += "systemd" |
| 12 | DEPENDS += "phosphor-ipmi-flash" |
| 13 | RDEPENDS_${PN} += "libsystemd" |
| 14 | RDEPENDS_${PN} += "bash" |
| 15 | |
| 16 | FILES_${PN} += "${datadir}/phosphor-ipmi-flash/config-bios.json" |
| 17 | |
| 18 | SRC_URI_append_kudo = " \ |
| 19 | file://phosphor-ipmi-flash-bios-update.service \ |
| 20 | file://config-bios.json \ |
| 21 | " |
| 22 | |
| 23 | SYSTEMD_PACKAGES = "${PN}" |
| 24 | SYSTEMD_SERVICE_${PN}_append_kudo = " \ |
| 25 | phosphor-ipmi-flash-bios-update.service \ |
| 26 | " |
| 27 | |
| 28 | do_install () { |
| 29 | install -d ${D}${datadir}/phosphor-ipmi-flash |
| 30 | install -m 0644 ${WORKDIR}/config-bios.json ${D}${datadir}/phosphor-ipmi-flash |
| 31 | install -d ${D}${systemd_system_unitdir} |
| 32 | install -m 0644 ${WORKDIR}/phosphor-ipmi-flash-bios-update.service ${D}${systemd_system_unitdir} |
| 33 | } |