Brad Bishop | 1932369 | 2019-04-05 15:28:33 -0400 | [diff] [blame] | 1 | SUMMARY = "Smart card library and applications" |
| 2 | DESCRIPTION = "OpenSC is a tool for accessing smart card devices. Basic\ |
| 3 | functionality (e.g. SELECT FILE, READ BINARY) should work on any ISO\ |
| 4 | 7816-4 compatible smart card. Encryption and decryption using private\ |
| 5 | keys on the smart card is possible with PKCS\ |
| 6 | such as the FINEID (Finnish Electronic IDentity) card. Swedish Posten\ |
| 7 | eID cards have also been confirmed to work." |
| 8 | |
| 9 | HOMEPAGE = "http://www.opensc-project.org/opensc/" |
| 10 | SECTION = "System Environment/Libraries" |
| 11 | LICENSE = "LGPLv2+" |
| 12 | LIC_FILES_CHKSUM = "file://COPYING;md5=7fbc338309ac38fefcd64b04bb903e34" |
| 13 | |
| 14 | #v0.19.0 |
Brad Bishop | 0e2770c | 2020-01-21 07:31:46 -0500 | [diff] [blame] | 15 | SRCREV = "45e29056ccde422e70ed3585084a7f150c632515" |
Brad Bishop | 1932369 | 2019-04-05 15:28:33 -0400 | [diff] [blame] | 16 | SRC_URI = "git://github.com/OpenSC/OpenSC \ |
Brad Bishop | 1932369 | 2019-04-05 15:28:33 -0400 | [diff] [blame] | 17 | " |
Brad Bishop | 8410d61 | 2019-11-25 09:40:59 -0500 | [diff] [blame] | 18 | DEPENDS = "virtual/libiconv openssl" |
Brad Bishop | 1932369 | 2019-04-05 15:28:33 -0400 | [diff] [blame] | 19 | |
| 20 | S = "${WORKDIR}/git" |
| 21 | inherit autotools pkgconfig bash-completion |
| 22 | |
| 23 | EXTRA_OECONF = " \ |
| 24 | --disable-static \ |
Brad Bishop | 1932369 | 2019-04-05 15:28:33 -0400 | [diff] [blame] | 25 | --disable-ctapi \ |
| 26 | --disable-doc \ |
| 27 | " |
| 28 | EXTRA_OEMAKE = "DESTDIR=${D}" |
| 29 | |
Brad Bishop | 8410d61 | 2019-11-25 09:40:59 -0500 | [diff] [blame] | 30 | PACKAGECONFIG ??= "pcsc" |
| 31 | |
| 32 | PACKAGECONFIG[openct] = "--enable-openct,--disable-openct,openct" |
Brad Bishop | e42b3e3 | 2020-01-15 22:08:42 -0500 | [diff] [blame] | 33 | PACKAGECONFIG[pcsc] = "--enable-pcsc,--disable-pcsc,pcsc-lite,pcsc-lite pcsc-lite-lib" |
Brad Bishop | 8410d61 | 2019-11-25 09:40:59 -0500 | [diff] [blame] | 34 | |
Brad Bishop | 1932369 | 2019-04-05 15:28:33 -0400 | [diff] [blame] | 35 | RDEPENDS_${PN} = "readline" |
| 36 | |
| 37 | FILES_${PN} += "\ |
| 38 | ${libdir}/opensc-pkcs11.so \ |
| 39 | ${libdir}/onepin-opensc-pkcs11.so \ |
| 40 | ${libdir}/pkcs11-spy.so \ |
| 41 | " |
| 42 | FILES_${PN}-dev += "\ |
| 43 | ${libdir}/pkcs11/opensc-pkcs11.so \ |
| 44 | ${libdir}/pkcs11/onepin-opensc-pkcs11.so \ |
| 45 | ${libdir}/pkcs11/pkcs11-spy.so \ |
| 46 | " |
Brad Bishop | 8410d61 | 2019-11-25 09:40:59 -0500 | [diff] [blame] | 47 | |
| 48 | BBCLASSEXTEND = "native" |