blob: e07b7410623e0f597e64cb02dee39784666cb7ad [file] [log] [blame]
Brad Bishop6e60e8b2018-02-01 10:27:11 -05001DESCRIPTION = "OCI systemd hook enables users to run systemd in docker and OCI"
2SECTION = "console/utils"
3LICENSE = "GPLv3"
4LIC_FILES_CHKSUM = "file://LICENSE;md5=d32239bcb673463ab874e80d47fae504"
5PRIORITY = "optional"
6
7DEPENDS = "yajl util-linux"
8
Brad Bishopd7bf8c12018-02-25 22:55:05 -05009SRCREV = "1ac958a4197a9ea52174812fc7d7d036af8140d3"
Brad Bishop6e60e8b2018-02-01 10:27:11 -050010SRC_URI = "git://github.com/projectatomic/oci-systemd-hook \
11 file://0001-selinux-drop-selinux-support.patch \
12 file://0001-configure-drop-selinux-support.patch \
Brad Bishop316dfdd2018-06-25 12:45:53 -040013 file://0001-Add-additional-cgroup-mounts-from-root-NS-automatica.patch \
Brad Bishop6e60e8b2018-02-01 10:27:11 -050014"
15
16PV = "0.0.1+git${SRCPV}"
17S = "${WORKDIR}/git"
18
19inherit autotools pkgconfig
20
21PACKAGECONFIG ??= ""
22PACKAGECONFIG[selinux] = ",,libselinux"
23
24EXTRA_OECONF += "--libexecdir=${libexecdir}/oci/hooks.d"
25
26# nothing to compile, we do it all in the install task
27do_compile[noexec] = "1"
28
29do_install() {
30 # Avoid building docs, and other artifacts by surgically calling the
31 # semi-internal target of "install-exec-am"
32 oe_runmake 'DESTDIR=${D}' install-exec-am
33}
34
35FILES_${PN} += "${libexecdir}/oci/hooks.d/"
36