blob: 01da03a473898f35fbbd6712b8819a74ca16af02 [file] [log] [blame]
Brad Bishop1a4b7ee2018-12-16 17:11:34 -08001SUMMARY = "An abstraction layer for touchscreen panel events"
2DESCRIPTION = "Tslib is an abstraction layer for touchscreen panel \
3events, as well as a filter stack for the manipulation of those events. \
4Tslib is generally used on embedded devices to provide a common user \
5space interface to touchscreen functionality."
6HOMEPAGE = "http://tslib.org/"
7
Brad Bishop1a4b7ee2018-12-16 17:11:34 -08008SECTION = "base"
Andrew Geissler9aee5002022-03-30 16:27:02 +00009LICENSE = "LGPL-2.0-or-later & GPL-2.0-or-later"
Brad Bishop1a4b7ee2018-12-16 17:11:34 -080010LIC_FILES_CHKSUM = "\
11 file://COPYING;md5=fc178bcd425090939a8b634d1d6a9594 \
12 file://tests/COPYING;md5=a23a74b3f4caf9616230789d94217acb \
13"
14
15SRC_URI = "https://github.com/kergoth/tslib/releases/download/${PV}/tslib-${PV}.tar.xz;downloadfilename=tslib-${PV}.tar.xz \
16 file://ts.conf \
17 file://tslib.sh \
Andrew Geisslerd221e032020-07-10 16:13:21 -050018 "
19SRC_URI[sha256sum] = "aaf0aed410a268d7b51385d07fe4d9d64312038e87c447ec8a24c8db0a15617a"
Brad Bishop1a4b7ee2018-12-16 17:11:34 -080020
21UPSTREAM_CHECK_URI = "https://github.com/kergoth/tslib/releases"
22
23inherit autotools pkgconfig
24
Andrew Geisslerf103a7f2021-05-07 16:09:40 -050025PACKAGECONFIG ??= "debounce dejitter evthres iir linear median pthres skip lowpass invert variance input touchkit waveshare"
Brad Bishop1a4b7ee2018-12-16 17:11:34 -080026PACKAGECONFIG[debounce] = "--enable-debounce,--disable-debounce"
27PACKAGECONFIG[dejitter] = "--enable-dejitter,--disable-dejitter"
Andrew Geisslerf103a7f2021-05-07 16:09:40 -050028PACKAGECONFIG[evthres] = "--enable-evthres,--disable-evthres"
Brad Bishop1a4b7ee2018-12-16 17:11:34 -080029PACKAGECONFIG[iir] = "--enable-iir,--disable-iir"
30PACKAGECONFIG[linear] = "--enable-linear,--disable-linear"
31PACKAGECONFIG[median] = "--enable-median,--disable-median"
32PACKAGECONFIG[pthres] = "--enable-pthres,--disable-pthres"
33PACKAGECONFIG[skip] = "--enable-skip,--disable-skip"
34PACKAGECONFIG[lowpass] = "--enable-lowpass,--disable-lowpass"
35PACKAGECONFIG[invert] = "--enable-invert,--disable-invert"
36PACKAGECONFIG[variance] = "--enable-variance,--disable-variance"
37PACKAGECONFIG[input] = "--enable-input,--disable-input"
38PACKAGECONFIG[tatung] = "--enable-tatung,--disable-tatung"
39PACKAGECONFIG[touchkit] = "--enable-touchkit,--disable-touchkit"
40PACKAGECONFIG[waveshare] = "--enable-waveshare,--disable-waveshare"
41PACKAGECONFIG[ucb1x00] = "--enable-ucb1x00,--disable-ucb1x00"
42PACKAGECONFIG[mk712] = "--enable-mk712,--disable-mk712"
43PACKAGECONFIG[h3600] = "--enable-h3600,--disable-h3600"
44PACKAGECONFIG[dmc] = "--enable-dmc,--disable-dmc"
45PACKAGECONFIG[linear-h2200] = "--enable-linear-h2200,--disable-linear-h2200"
46PACKAGECONFIG[corgi] = "--enable-corgi,--disable-corgi"
47PACKAGECONFIG[collie] = "--enable-collie,--disable-collie"
48PACKAGECONFIG[arctic2] = "--enable-arctic2,--disable-arctic2"
49PACKAGECONFIG[dmc_dus3000] = "--enable-dmc_dus3000,--disable-dmc_dus3000"
50PACKAGECONFIG[cy8mrln-palmpre] = "--enable-cy8mrln-palmpre,--disable-cy8mrln-palmpre"
51PACKAGECONFIG[galax] = "--enable-galax,--disable-galax"
Andrew Geisslerf103a7f2021-05-07 16:09:40 -050052PACKAGECONFIG[one-wire-ts-input] = "--enable-one-wire-ts-input,--disable-one-wire-ts-input"
Brad Bishop1a4b7ee2018-12-16 17:11:34 -080053PACKAGECONFIG[debug] = "--enable-debug,--disable-debug"
54
Patrick Williams213cb262021-08-07 19:21:33 -050055do_install:prepend() {
Brad Bishop1a4b7ee2018-12-16 17:11:34 -080056 install -m 0644 ${WORKDIR}/ts.conf ${S}/etc/ts.conf
57}
58
Patrick Williams213cb262021-08-07 19:21:33 -050059do_install:append() {
Brad Bishop1a4b7ee2018-12-16 17:11:34 -080060 install -d ${D}${sysconfdir}/profile.d/
61 install -m 0755 ${WORKDIR}/tslib.sh ${D}${sysconfdir}/profile.d/
62}
63
Patrick Williams213cb262021-08-07 19:21:33 -050064RPROVIDES:tslib-conf = "libts-0.0-conf"
Brad Bishop1a4b7ee2018-12-16 17:11:34 -080065
66PACKAGES =+ "tslib-conf tslib-tests tslib-calibrate tslib-uinput"
Patrick Williams213cb262021-08-07 19:21:33 -050067DEBIAN_NOAUTONAME:tslib-conf = "1"
68DEBIAN_NOAUTONAME:tslib-tests = "1"
69DEBIAN_NOAUTONAME:tslib-calibrate = "1"
70DEBIAN_NOAUTONAME:tslib-uinput = "1"
Brad Bishop1a4b7ee2018-12-16 17:11:34 -080071
Patrick Williams213cb262021-08-07 19:21:33 -050072RDEPENDS:${PN} = "tslib-conf"
73RRECOMMENDS:${PN} = "pointercal"
Brad Bishop1a4b7ee2018-12-16 17:11:34 -080074
Patrick Williams213cb262021-08-07 19:21:33 -050075FILES:${PN}-dev += "${libdir}/ts/*.la"
76FILES:tslib-conf = "${sysconfdir}/ts.conf ${sysconfdir}/profile.d/tslib.sh ${datadir}/tslib"
77FILES:${PN} = "${libdir}/*.so.* ${libdir}/ts/*.so*"
78FILES:tslib-calibrate += "${bindir}/ts_calibrate"
79FILES:tslib-uinput += "${bindir}/ts_uinput"
Brad Bishop1a4b7ee2018-12-16 17:11:34 -080080
Patrick Williams213cb262021-08-07 19:21:33 -050081FILES:tslib-tests = "${bindir}/ts_harvest ${bindir}/ts_print ${bindir}/ts_print_raw ${bindir}/ts_print_mt \
Brad Bishop2f973922019-11-11 07:58:48 -050082 ${bindir}/ts_test ${bindir}/ts_test_mt ${bindir}/ts_verify ${bindir}/ts_finddev ${bindir}/ts_conf"
Andrew Geissler028142b2023-05-05 11:29:21 -050083
84BBCLASSEXTEND = "native nativesdk"