Brad Bishop | 1932369 | 2019-04-05 15:28:33 -0400 | [diff] [blame] | 1 | SUMMARY = "A C program to run all installed ptests" |
| 2 | DESCRIPTION = "The ptest-runner2 package installs a ptest-runner \ |
| 3 | program which loops through all installed ptest test suites and \ |
| 4 | runs them in sequence." |
| 5 | HOMEPAGE = "http://git.yoctoproject.org/cgit/cgit.cgi/ptest-runner2/about/" |
| 6 | |
| 7 | LICENSE = "GPLv2" |
| 8 | LIC_FILES_CHKSUM = "file://LICENSE;md5=751419260aa954499f7abaabaa882bbe" |
| 9 | |
Brad Bishop | 15ae250 | 2019-06-18 21:44:24 -0400 | [diff] [blame^] | 10 | SRCREV = "63d097cc46142157931682fed076b5407757a0bd" |
Brad Bishop | 1932369 | 2019-04-05 15:28:33 -0400 | [diff] [blame] | 11 | PV = "2.3.1+git${SRCPV}" |
| 12 | |
Brad Bishop | d89cb5f | 2019-04-10 09:02:41 -0400 | [diff] [blame] | 13 | SRC_URI = "git://git.yoctoproject.org/ptest-runner2 \ |
| 14 | file://0001-utils-Ensure-stdout-stderr-are-flushed.patch \ |
| 15 | file://0002-use-process-groups-when-spawning.patch \ |
Brad Bishop | 15ae250 | 2019-06-18 21:44:24 -0400 | [diff] [blame^] | 16 | file://0003-utils-Ensure-pipes-are-read-after-exit.patch \ |
| 17 | file://0004-utils-ensure-child-can-be-session-leader.patch \ |
| 18 | " |
Brad Bishop | d89cb5f | 2019-04-10 09:02:41 -0400 | [diff] [blame] | 19 | |
Brad Bishop | 1932369 | 2019-04-05 15:28:33 -0400 | [diff] [blame] | 20 | S = "${WORKDIR}/git" |
| 21 | |
| 22 | FILES_${PN} = "${bindir}/ptest-runner" |
| 23 | |
| 24 | EXTRA_OEMAKE = "-e MAKEFLAGS= CFLAGS="${CFLAGS} -DDEFAULT_DIRECTORY=\\\"${libdir}\\\""" |
| 25 | |
| 26 | do_compile () { |
| 27 | oe_runmake |
| 28 | } |
| 29 | |
| 30 | do_install () { |
| 31 | install -D -m 0755 ${S}/ptest-runner ${D}${bindir}/ptest-runner |
| 32 | } |