Andrew Geissler | 82c905d | 2020-04-13 13:39:40 -0500 | [diff] [blame] | 1 | SUMMARY = "Fast, multi-threaded malloc() and nifty performance analysis tools" |
| 2 | HOMEPAGE = "https://github.com/gperftools/gperftools" |
Andrew Geissler | 32b1199 | 2021-03-31 13:37:05 -0500 | [diff] [blame] | 3 | DESCRIPTION = "The gperftools, previously called google-perftools, package contains some \ |
| 4 | utilities to improve and analyze the performance of C++ programs. \ |
| 5 | Included are an optimized thread-caching malloc() and cpu and heap profiling utilities. \ |
| 6 | " |
| 7 | |
Andrew Geissler | 82c905d | 2020-04-13 13:39:40 -0500 | [diff] [blame] | 8 | LICENSE = "BSD-3-Clause" |
| 9 | LIC_FILES_CHKSUM = "file://COPYING;md5=762732742c73dc6c7fbe8632f06c059a" |
| 10 | |
Patrick Williams | 213cb26 | 2021-08-07 19:21:33 -0500 | [diff] [blame] | 11 | DEPENDS:append:libc-musl = " libucontext" |
Andrew Geissler | 32b1199 | 2021-03-31 13:37:05 -0500 | [diff] [blame] | 12 | |
Andrew Geissler | 615f2f1 | 2022-07-15 14:00:58 -0500 | [diff] [blame] | 13 | SRCREV = "bf8b714bf5075d0a6f2f28504b43095e2b1e11c5" |
Andrew Geissler | 595f630 | 2022-01-24 19:11:47 +0000 | [diff] [blame] | 14 | SRC_URI = "git://github.com/gperftools/gperftools;branch=master;protocol=https \ |
Andrew Geissler | 82c905d | 2020-04-13 13:39:40 -0500 | [diff] [blame] | 15 | file://0001-Support-Atomic-ops-on-clang.patch \ |
Andrew Geissler | 82c905d | 2020-04-13 13:39:40 -0500 | [diff] [blame] | 16 | file://0001-disbale-heap-checkers-and-debug-allocator-on-musl.patch \ |
| 17 | file://disable_libunwind_aarch64.patch \ |
| 18 | file://sgidef.patch \ |
Andrew Geissler | 517393d | 2023-01-13 08:55:19 -0600 | [diff] [blame] | 19 | file://0001-Define-off64_t-as-off_t-on-musl.patch \ |
Andrew Geissler | 82c905d | 2020-04-13 13:39:40 -0500 | [diff] [blame] | 20 | " |
| 21 | |
Patrick Williams | 213cb26 | 2021-08-07 19:21:33 -0500 | [diff] [blame] | 22 | SRC_URI:append:libc-musl = " file://ppc-musl.patch" |
Andrew Geissler | 32b1199 | 2021-03-31 13:37:05 -0500 | [diff] [blame] | 23 | |
Andrew Geissler | 82c905d | 2020-04-13 13:39:40 -0500 | [diff] [blame] | 24 | inherit autotools |
| 25 | |
| 26 | S = "${WORKDIR}/git" |
| 27 | |
| 28 | # On mips, we have the following error. |
| 29 | # do_page_fault(): sending SIGSEGV to ls for invalid read access from 00000008 |
| 30 | # Segmentation fault (core dumped) |
Patrick Williams | 213cb26 | 2021-08-07 19:21:33 -0500 | [diff] [blame] | 31 | COMPATIBLE_HOST:mipsarch = "null" |
| 32 | COMPATIBLE_HOST:riscv64 = "null" |
| 33 | COMPATIBLE_HOST:riscv32 = "null" |
Andrew Geissler | 82c905d | 2020-04-13 13:39:40 -0500 | [diff] [blame] | 34 | |
| 35 | # Disable thumb1 |
| 36 | # {standard input}: Assembler messages: |
| 37 | # {standard input}:434: Error: lo register required -- `ldr pc,[sp]' |
| 38 | # Makefile:4538: recipe for target 'src/base/libtcmalloc_la-linuxthreads.lo' failed |
Patrick Williams | 213cb26 | 2021-08-07 19:21:33 -0500 | [diff] [blame] | 39 | ARM_INSTRUCTION_SET:armv5 = "arm" |
| 40 | ARM_INSTRUCTION_SET:toolchain-clang:arm = "arm" |
Andrew Geissler | 82c905d | 2020-04-13 13:39:40 -0500 | [diff] [blame] | 41 | |
Andrew Geissler | 9aee500 | 2022-03-30 16:27:02 +0000 | [diff] [blame] | 42 | EXTRA_OECONF:append:libc-musl:powerpc64le = " --disable-cpu-profiler" |
| 43 | EXTRA_OECONF:append:libc-musl:powerpc = " --disable-cpu-profiler" |
Andrew Geissler | 82c905d | 2020-04-13 13:39:40 -0500 | [diff] [blame] | 44 | PACKAGECONFIG ?= "libunwind static" |
Patrick Williams | 213cb26 | 2021-08-07 19:21:33 -0500 | [diff] [blame] | 45 | PACKAGECONFIG:remove:arm:libc-musl = "libunwind" |
| 46 | PACKAGECONFIG:remove:riscv64 = "libunwind" |
| 47 | PACKAGECONFIG:remove:riscv32 = "libunwind" |
Andrew Geissler | 82c905d | 2020-04-13 13:39:40 -0500 | [diff] [blame] | 48 | |
| 49 | PACKAGECONFIG[libunwind] = "--enable-libunwind,--disable-libunwind,libunwind" |
| 50 | PACKAGECONFIG[static] = "--enable-static,--disable-static," |
| 51 | |
| 52 | PACKAGE_BEFORE_PN += "libtcmalloc-minimal" |
Patrick Williams | 213cb26 | 2021-08-07 19:21:33 -0500 | [diff] [blame] | 53 | FILES:libtcmalloc-minimal = "${libdir}/libtcmalloc_minimal*${SOLIBS} ${libdir}/libtcmalloc_minimal_debug*${SOLIBS}" |
Andrew Geissler | 82c905d | 2020-04-13 13:39:40 -0500 | [diff] [blame] | 54 | |
| 55 | # pprof tool requires Getopt::long and POSIX perl5 modules. |
| 56 | # Also runs `objdump` on each cpuprofile data file |
Patrick Williams | 213cb26 | 2021-08-07 19:21:33 -0500 | [diff] [blame] | 57 | RDEPENDS:${PN} += " \ |
Andrew Geissler | 32b1199 | 2021-03-31 13:37:05 -0500 | [diff] [blame] | 58 | binutils \ |
| 59 | curl \ |
| 60 | perl-module-carp \ |
| 61 | perl-module-cwd \ |
| 62 | perl-module-getopt-long \ |
| 63 | perl-module-overloading \ |
| 64 | perl-module-posix \ |
| 65 | " |
Andrew Geissler | 82c905d | 2020-04-13 13:39:40 -0500 | [diff] [blame] | 66 | |
Patrick Williams | 213cb26 | 2021-08-07 19:21:33 -0500 | [diff] [blame] | 67 | RDEPENDS:${PN} += "libtcmalloc-minimal (= ${EXTENDPKGV})" |