Brad Bishop | 2d39a06 | 2019-10-28 08:33:36 -0400 | [diff] [blame] | 1 | SUMMARY = "Snowball compiler and stemming algorithms" |
| 2 | HOMEPAGE = "https://snowballstem.org/" |
| 3 | LICENSE = "BSD-3-Clause" |
William A. Kennington III | b95905d | 2021-06-02 12:40:56 -0700 | [diff] [blame] | 4 | LIC_FILES_CHKSUM = "file://COPYING;md5=19139aaf3c8c8fa1ca6edd59c072fb9f" |
Brad Bishop | 2d39a06 | 2019-10-28 08:33:36 -0400 | [diff] [blame] | 5 | |
Patrick Williams | 8e7b46e | 2023-05-01 14:19:06 -0500 | [diff] [blame] | 6 | DEPENDS:append:class-target = " ${BPN}-native" |
Brad Bishop | 2d39a06 | 2019-10-28 08:33:36 -0400 | [diff] [blame] | 7 | |
Patrick Williams | 8e7b46e | 2023-05-01 14:19:06 -0500 | [diff] [blame] | 8 | SRC_URI = "git://github.com/snowballstem/snowball.git;branch=master;protocol=https \ |
| 9 | file://0001-Build-so-lib.patch \ |
| 10 | " |
| 11 | SRCREV = "48a67a2831005f49c48ec29a5837640e23e54e6b" |
Brad Bishop | 2d39a06 | 2019-10-28 08:33:36 -0400 | [diff] [blame] | 12 | S = "${WORKDIR}/git" |
Patrick Williams | 8e7b46e | 2023-05-01 14:19:06 -0500 | [diff] [blame] | 13 | |
Brad Bishop | 2d39a06 | 2019-10-28 08:33:36 -0400 | [diff] [blame] | 14 | LIBVER = "0.0.0" |
| 15 | |
| 16 | inherit lib_package |
| 17 | |
Patrick Williams | 213cb26 | 2021-08-07 19:21:33 -0500 | [diff] [blame] | 18 | do_compile:prepend:class-target() { |
Brad Bishop | 2d39a06 | 2019-10-28 08:33:36 -0400 | [diff] [blame] | 19 | # use native tools |
| 20 | sed -i 's:./snowball :snowball :g' ${S}/GNUmakefile |
| 21 | } |
| 22 | |
| 23 | do_install() { |
| 24 | install -d ${D}${bindir} |
| 25 | install -m 755 ${S}/snowball ${D}${bindir} |
| 26 | install -m 755 ${S}/stemwords ${D}${bindir} |
| 27 | |
| 28 | install -d ${D}${libdir} |
| 29 | install -m 755 ${S}/libstemmer.so.${LIBVER} ${D}${libdir}/ |
| 30 | ln -s libstemmer.so.${LIBVER} ${D}${libdir}/libstemmer.so.0 |
| 31 | ln -s libstemmer.so.${LIBVER} ${D}${libdir}/libstemmer.so |
| 32 | |
| 33 | install -d ${D}${includedir} |
Patrick Williams | 8e7b46e | 2023-05-01 14:19:06 -0500 | [diff] [blame] | 34 | install -m 644 ${S}/include/*.h ${D}${includedir} |
Brad Bishop | 2d39a06 | 2019-10-28 08:33:36 -0400 | [diff] [blame] | 35 | } |
Patrick Williams | 8e7b46e | 2023-05-01 14:19:06 -0500 | [diff] [blame] | 36 | |
| 37 | BBCLASSEXTEND = "native" |