blob: 6b340a18cee311504375066b51d2d8cebdd05735 [file] [log] [blame]
Andrew Geissler82c905d2020-04-13 13:39:40 -05001SUMMARY = "A pure Python netlink and Linux network configuration library"
Andrew Geissler8f840682023-07-21 09:09:43 -05002LICENSE = "GPL-2.0-or-later | Apache-2.0"
3LIC_FILES_CHKSUM = "file://LICENSE;md5=dccbff78d7d79ae7e53953d43445c6e6 \
4 file://LICENSE.GPL-2.0-or-later;md5=b234ee4d69f5fce4486a80fdaf4a4263 \
5 file://LICENSE.Apache-2.0;md5=34281e312165f843a2b7d1f114fe65ce"
Andrew Geissler82c905d2020-04-13 13:39:40 -05006
Patrick Williams169d7bc2024-01-05 11:33:25 -06007SRC_URI[sha256sum] = "cc2f90aad1517cb0b301041f678cc8d3c3427c26e53f15c78c93c67928d89a02"
Andrew Geissler82c905d2020-04-13 13:39:40 -05008
9inherit setuptools3 pypi ptest
10
Patrick Williams213cb262021-08-07 19:21:33 -050011RDEPENDS:${PN} += " \
Patrick Williamsb542dec2023-06-09 01:26:37 -050012 python3-ctypes \
Patrick Williamsb542dec2023-06-09 01:26:37 -050013 python3-io \
14 python3-json \
15 python3-fcntl \
16 python3-logging \
17 python3-multiprocessing \
18 python3-pickle \
19 python3-pkgutil \
20 python3-pprint \
21 python3-shell \
22 python3-unixadmin \
Andrew Geissler82c905d2020-04-13 13:39:40 -050023"
24
25SRC_URI += " \
Patrick Williamsb542dec2023-06-09 01:26:37 -050026 file://run-ptest \
Andrew Geissler82c905d2020-04-13 13:39:40 -050027"
28
Patrick Williams213cb262021-08-07 19:21:33 -050029RDEPENDS:${PN}-ptest += " \
Patrick Williamsb542dec2023-06-09 01:26:37 -050030 python3-pytest \
31 python3-fcntl \
Andrew Geissler20137392023-10-12 04:59:14 -060032 python3-sqlite3 \
Andrew Geissler82c905d2020-04-13 13:39:40 -050033"
34
35do_install_ptest() {
Patrick Williamsb542dec2023-06-09 01:26:37 -050036 install -d ${D}${PTEST_PATH}/tests
37 cp -rf ${S}/tests/* ${D}${PTEST_PATH}/tests/
Andrew Geissler5082cc72023-09-11 08:41:39 -040038 sed -e "s|'test_unit|'tests/test_unit|g" -i ${D}${PTEST_PATH}/tests/test_unit/test_nlmsg/test_marshal.py \
39 ${D}${PTEST_PATH}/tests/test_unit/test_iproute_match/test_match.py
Andrew Geissler82c905d2020-04-13 13:39:40 -050040}