Patrick Williams | ac13d5f | 2023-11-24 18:59:46 -0600 | [diff] [blame] | 1 | SUMMARY = "Python wrapper around rapidjson" |
| 2 | HOMEPAGE = "https://github.com/python-rapidjson/python-rapidjson" |
| 3 | |
| 4 | LICENSE = "MIT" |
| 5 | LIC_FILES_CHKSUM = "file://LICENSE;md5=4daf3929156304df67003c33274a98bd" |
| 6 | |
Patrick Williams | 169d7bc | 2024-01-05 11:33:25 -0600 | [diff] [blame^] | 7 | SRC_URI[sha256sum] = "26806f0a658c34b48d2951d8d3f846ca9deb93a34e664ef436db632a188b6779" |
Patrick Williams | ac13d5f | 2023-11-24 18:59:46 -0600 | [diff] [blame] | 8 | |
| 9 | # Inheriting ptest provides functionality for packaging and installing runtime tests for this recipe |
Patrick Williams | 169d7bc | 2024-01-05 11:33:25 -0600 | [diff] [blame^] | 10 | inherit setuptools3 pypi ptest |
| 11 | |
| 12 | PYPI_PACKAGE = "python-rapidjson" |
Patrick Williams | ac13d5f | 2023-11-24 18:59:46 -0600 | [diff] [blame] | 13 | |
| 14 | SETUPTOOLS_BUILD_ARGS += " --rj-include-dir=${RECIPE_SYSROOT}${includedir}" |
| 15 | |
| 16 | # run-ptest is a shell script that starts the test suite |
| 17 | SRC_URI += " \ |
| 18 | file://run-ptest \ |
| 19 | " |
| 20 | |
| 21 | DEPENDS += " \ |
| 22 | rapidjson \ |
| 23 | " |
| 24 | |
| 25 | # Adding required python package for the ptest (pytest and pytest->automake report translation) |
| 26 | RDEPENDS:${PN}-ptest += " \ |
| 27 | ${PYTHON_PN}-pytest \ |
| 28 | ${PYTHON_PN}-unittest-automake-output \ |
| 29 | ${PYTHON_PN}-pytz \ |
| 30 | " |
| 31 | |
| 32 | RDEPENDS:${PN} += " \ |
| 33 | ${PYTHON_PN}-core \ |
| 34 | " |
| 35 | |
| 36 | # Installing the test suite on the target |
| 37 | do_install_ptest() { |
| 38 | install -d ${D}${PTEST_PATH}/tests |
| 39 | cp -rf ${S}/tests/* ${D}${PTEST_PATH}/tests/ |
| 40 | } |