Brad Bishop | d7bf8c1 | 2018-02-25 22:55:05 -0500 | [diff] [blame] | 1 | SUMMARY = "Cap'n Proto serialization/RPC system" |
| 2 | DESCRIPTION = "Cap’n Proto is an insanely fast data interchange format and capability-based RPC system. " |
| 3 | HOMEPAGE = "https://github.com/sandstorm-io/capnproto" |
| 4 | SECTION = "console/tools" |
Brad Bishop | d7bf8c1 | 2018-02-25 22:55:05 -0500 | [diff] [blame] | 5 | LICENSE = "MIT" |
| 6 | LIC_FILES_CHKSUM = "file://../LICENSE;md5=0a5b5b742baf10cc1c158579eba7fb1d" |
| 7 | |
Brad Bishop | d7bf8c1 | 2018-02-25 22:55:05 -0500 | [diff] [blame] | 8 | SRC_URI = "git://github.com/sandstorm-io/capnproto.git;branch=release-${PV}" |
Brad Bishop | 1a4b7ee | 2018-12-16 17:11:34 -0800 | [diff] [blame^] | 9 | SRCREV = "c949a18da5f041a36cc218c5c4b79c7705999b4f" |
| 10 | |
| 11 | S = "${WORKDIR}/git/c++" |
| 12 | |
| 13 | inherit cmake |
Brad Bishop | d7bf8c1 | 2018-02-25 22:55:05 -0500 | [diff] [blame] | 14 | |
| 15 | EXTRA_OECMAKE += "\ |
| 16 | -DBUILD_TESTING=OFF \ |
| 17 | " |
| 18 | |
Brad Bishop | 1a4b7ee | 2018-12-16 17:11:34 -0800 | [diff] [blame^] | 19 | FILES_${PN}-compiler = "${bindir}" |
Brad Bishop | d7bf8c1 | 2018-02-25 22:55:05 -0500 | [diff] [blame] | 20 | |
| 21 | PACKAGE_BEFORE_PN = "${PN}-compiler" |
| 22 | RDEPENDS_${PN}-dev += "${PN}-compiler" |
| 23 | |
Brad Bishop | d7bf8c1 | 2018-02-25 22:55:05 -0500 | [diff] [blame] | 24 | BBCLASSEXTEND = "native nativesdk" |