blob: 27e369a89a5063d3389d6a85cb3ec57649989b05 [file] [log] [blame]
Andrew Geissler595f6302022-01-24 19:11:47 +00001SUMMARY = "Library for reading extended image information (EXIF) from JPEG files"
2DESCRIPTION = "libexif is a library for parsing, editing, and saving EXIF data. It is \
3intended to replace lots of redundant implementations in command-line \
4utilities and programs with GUIs."
5HOMEPAGE = "https://libexif.github.io/"
6SECTION = "libs"
Andrew Geissler7e0e3c02022-02-25 20:34:39 +00007LICENSE = "LGPL-2.1-only"
Andrew Geissler595f6302022-01-24 19:11:47 +00008LIC_FILES_CHKSUM = "file://COPYING;md5=243b725d71bb5df4a1e5920b344b86ad"
9
10def version_underscore(v):
11 return "_".join(v.split("."))
12
Andrew Geissler87f5cff2022-09-30 13:13:31 -050013SRC_URI = "${GITHUB_BASE_URI}/download/v${PV}/libexif-${PV}.tar.bz2 \
Patrick Williams2a254922023-08-11 09:48:11 -050014 file://0001-Add-serial-tests-config-needed-by-ptest.patch \
15 file://run-ptest \
Andrew Geissler595f6302022-01-24 19:11:47 +000016 "
17
18SRC_URI[sha256sum] = "d47564c433b733d83b6704c70477e0a4067811d184ec565258ac563d8223f6ae"
19
Patrick Williams2a254922023-08-11 09:48:11 -050020inherit autotools gettext github-releases ptest
Andrew Geissler595f6302022-01-24 19:11:47 +000021
22EXTRA_OECONF += "--disable-docs"
23
Patrick Williams2a254922023-08-11 09:48:11 -050024do_compile_ptest() {
25 oe_runmake -C test buildtest-TESTS
26}
27
28do_install_ptest() {
29 install ${B}/test/test*[!\.o] ${D}${PTEST_PATH}
30 for f in ${D}${PTEST_PATH}/test*; do
31 sed -i "s/\(LD_LIBRARY_PATH=\).*\(:\$LD_LIBRARY_PATH\)\"/\1.\2/" $f
32 done
33
34 install ${B}/test/Makefile ${D}${PTEST_PATH}
35 sed -i -e "/^srcdir/c srcdir = \$\{PWD\}" ${D}${PTEST_PATH}/Makefile
36
37 install -d ${D}${PTEST_PATH}/nls
38 install ${B}/test/nls/*[!\.o] ${D}${PTEST_PATH}/nls
39 install -d ${D}${PTEST_PATH}/.libs
40 install ${B}/test/.libs/* ${D}${PTEST_PATH}/.libs
41
42 install ${S}/test/*.sh ${D}${PTEST_PATH}
43
44 install -d ${D}${PTEST_PATH}/testdata
45 install ${S}/test/testdata/* ${D}${PTEST_PATH}/testdata
46}
47
48RDEPENDS:${PN}-ptest += "make bash"
49
Andrew Geissler595f6302022-01-24 19:11:47 +000050BBCLASSEXTEND = "native nativesdk"