Patrick Williams | 8e7b46e | 2023-05-01 14:19:06 -0500 | [diff] [blame] | 1 | SUMMARY = "Provides API for encoding/decoding of data to/from D-Bus wire format" |
| 2 | DESCRIPTION = "This crate provides API for encoding/decoding of data to/from D-Bus wire format.\ |
| 3 | This binary wire format is simple and very efficient and hence useful outside of D-Bus context as well.\ |
| 4 | A modified form of this format, GVariant is very commonly used for efficient storage of arbitrary \ |
| 5 | data and is also supported by this crate." |
| 6 | HOMEPAGE = "https://gitlab.freedesktop.org/dbus/zbus/" |
| 7 | LICENSE = "MIT" |
| 8 | LIC_FILES_CHKSUM = "file://LICENSE;md5=b377b220f43d747efdec40d69fcaa69d" |
| 9 | |
Andrew Geissler | 028142b | 2023-05-05 11:29:21 -0500 | [diff] [blame] | 10 | DEPENDS += "${@bb.utils.contains('DISTRO_FEATURES', 'ptest', 'glib-2.0', '', d)}" |
| 11 | |
Patrick Williams | 8e7b46e | 2023-05-01 14:19:06 -0500 | [diff] [blame] | 12 | SRC_URI = " \ |
| 13 | git://gitlab.freedesktop.org/dbus/zbus;protocol=https;branch=main;subpath=zvariant \ |
| 14 | file://0001-Tweak-zvariant-crate-config.patch;striplevel=2 \ |
| 15 | " |
| 16 | |
| 17 | SRCREV = "07506776fab5f58e029760bb4b288f670c7eecd6" |
| 18 | S = "${WORKDIR}/zvariant" |
| 19 | |
| 20 | python do_clean_lic_file_symlink() { |
| 21 | bb.utils.remove("LICENCE") |
| 22 | } |
| 23 | |
| 24 | addtask clean_lic_file_symlink after do_unpack before do_patch |
| 25 | |
Andrew Geissler | 028142b | 2023-05-05 11:29:21 -0500 | [diff] [blame] | 26 | inherit ptest-cargo pkgconfig cargo-update-recipe-crates |
Patrick Williams | 8e7b46e | 2023-05-01 14:19:06 -0500 | [diff] [blame] | 27 | |
| 28 | # Remove this when the recipe is reproducible |
| 29 | EXCLUDE_FROM_WORLD = "1" |
| 30 | |
| 31 | require ${BPN}-crates.inc |
| 32 | require ${BPN}-git-crates.inc |
Andrew Geissler | 028142b | 2023-05-05 11:29:21 -0500 | [diff] [blame] | 33 | |
| 34 | # zvariant is an indermediate product for the zbus project |
| 35 | # and so, it provided only a static lib (rlib) which fall only |
| 36 | # in -dev package |
| 37 | ALLOW_EMPTY:${PN} = "1" |